<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012005150002001">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="description" content="The new generation of Lady Cricket Cranes, however, has been fortunate enough to get a lot of international cricket in ICC or Regional Events."><meta name="robots" content="index, follow"><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Who makes the next generation of Lady Cricket Cranes?"><meta property="og:description" content="The new generation of Lady Cricket Cranes, however, has been fortunate enough to get a lot of international cricket in ICC or Regional Events."><meta property="og:url" content="https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/"><meta property="og:site_name" content="Kawowo Sports"><meta property="article:publisher" content="https://www.facebook.com/kawowosports"><meta property="article:author" content="https://www.facebook.com/musali.denis"><meta property="article:published_time" content="2020-05-30T13:33:42+00:00"><meta property="article:modified_time" content="2020-05-30T13:56:22+00:00"><meta property="og:image" content="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?fit=2048%2C1211&amp;ssl=1"><meta property="og:image:width" content="2048"><meta property="og:image:height" content="1211"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="@https://www.twitter.com/deniszenk"><meta name="twitter:site" content="@KawowoSports"><meta name="generator" content="Site Kit by Google 1.8.1"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Kawowo Sports"><meta name="application-name" content="Kawowo Sports"><meta name="generator" content="AMP Plugin v1.5.3; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><title>Who makes the next generation of Lady Cricket Cranes?</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" async></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" async custom-element="amp-bind"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://kawowo.com/wp-content/uploads/2020/04/icon-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="sportspress-roboto-css" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500&amp;subset=cyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext%2Cvietnamese&amp;ver=2.7" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css?family=Baloo+Thambi+2:400,500,600,700,800&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- This site is optimized with the Yoast SEO Premium plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://kawowo.com/#organization","name":"Kawowo Sports","url":"https://kawowo.com/","sameAs":["https://www.facebook.com/kawowosports","https://www.instagram.com/kawowosports/","https://www.youtube.com/c/Kawowo","https://en.wikipedia.org/wiki/Kawowo_Sports","https://twitter.com/KawowoSports"],"logo":{"@type":"ImageObject","@id":"https://kawowo.com/#logo","inLanguage":"en-US","url":"","caption":"Kawowo Sports"},"image":{"@id":"https://kawowo.com/#logo"}},{"@type":"WebSite","@id":"https://kawowo.com/#website","url":"https://kawowo.com/","name":"Kawowo Sports","description":"East Africa&#039;s hub for Sports content","publisher":{"@id":"https://kawowo.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://kawowo.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?fit=2048%2C1211&ssl=1","width":2048,"height":1211,"caption":"Immaculate Nakisuyi"},{"@type":"WebPage","@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#webpage","url":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/","name":"Who makes the next generation of Lady Cricket Cranes?","isPartOf":{"@id":"https://kawowo.com/#website"},"primaryImageOfPage":{"@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#primaryimage"},"datePublished":"2020-05-30T13:33:42+00:00","dateModified":"2020-05-30T13:56:22+00:00","description":"The new generation of Lady Cricket Cranes, however, has been fortunate enough to get a lot of international cricket in ICC or Regional Events.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/"]}]},{"@type":"Article","@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#article","isPartOf":{"@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#webpage"},"author":{"@id":"https://kawowo.com/#/schema/person/98c33f7c00bae454439bea20d0bd310d"},"headline":"Who makes the next generation of Lady Cricket Cranes?","datePublished":"2020-05-30T13:33:42+00:00","dateModified":"2020-05-30T13:56:22+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#webpage"},"publisher":{"@id":"https://kawowo.com/#organization"},"image":{"@id":"https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#primaryimage"},"articleSection":"Cricket","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#respond"]}]},{"@type":["Person"],"@id":"https://kawowo.com/#/schema/person/98c33f7c00bae454439bea20d0bd310d","name":"Denis Musali","image":{"@type":"ImageObject","@id":"https://kawowo.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=96&d=mm&r=g","caption":"Denis Musali"},"description":"Denis has represented Uganda in international cricket events including the World Cup. He is currently the captain of Wanderers Cricket Club.","sameAs":["https://www.facebook.com/musali.denis","https://twitter.com/https://www.twitter.com/deniszenk"]}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Feed" href="https://kawowo.com/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Comments Feed" href="https://kawowo.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Who makes the next generation of Lady Cricket Cranes? Comments Feed" href="https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/feed/"><link rel="https://api.w.org/" href="https://kawowo.com/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kawowo.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kawowo.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://kawowo.com/?p=153883"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2020%2F05%2F30%2Fwho-makes-the-next-generation-of-lady-cricket-cranes%2F"><link rel="alternate" type="text/xml+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2020%2F05%2F30%2Fwho-makes-the-next-generation-of-lady-cricket-cranes%2F&amp;format=xml"><link rel="manifest" href="https://kawowo.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><!-- Jetpack Google Analytics --><!-- End Jetpack Google Analytics --></head>

<body class="post-template-default single single-post postid-153883 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-sb h-cl h-dh has-tertiary-menu has-sidebar has-featured-image single-featured-image-default">
		<div class="newspack_global_ad global_above_header">
			<div id="div-gpt-amp-kawowo-web-5ed2735d001eb-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-kawowo-web-5ed2735d001eb-970x90"><amp-ad width="970px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> 
		</div>
		
	<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

				<nav toolbar="(min-width: 767px)" toolbar-target="tertiary-nav-contain" class="tertiary-menu nav3" aria-label="Tertiary Menu">
			<ul id="menu-tertiary-menu" class="menu"><li id="menu-item-151624" class="menu-highlight menu-item menu-item-type-post_type menu-item-object-page menu-item-151624"><a href="https://kawowo.com/support/">Support Us!</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav toolbar="(min-width: 767px)" toolbar-target="site-navigation" class="main-navigation nav1" aria-label="Top Menu">
		<ul id="menu-main-menu" class="main-menu"><li id="menu-item-151573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151573"><a href="https://kawowo.com/">Home</a></li>
<li id="menu-item-151574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151574"><a href="https://kawowo.com/football/">Football</a></li>
<li id="menu-item-151575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151575"><a href="https://kawowo.com/rugby/">Rugby</a></li>
<li id="menu-item-151576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151576"><a href="https://kawowo.com/motorsport/">Motorsport</a></li>
<li id="menu-item-151577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151577"><a href="https://kawowo.com/basketball/">Basketball</a></li>
<li id="menu-item-151578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151578"><a href="https://kawowo.com/golf/">Golf</a></li>
<li id="menu-item-151579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151579"><a href="https://kawowo.com/athletics/">Athletics</a></li>
<li id="menu-item-151580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151580"><a href="https://kawowo.com/cricket/">Cricket</a></li>
<li id="menu-item-151581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151581"><a href="https://kawowo.com/op-eds/">Op-Eds</a></li>
<li id="menu-item-151582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151582"><a href="https://kawowo.com/boxing/">Boxing</a></li>
<li id="menu-item-151583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151583"><a aria-haspopup="true" aria-expanded="false">More</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151584"><a href="https://kawowo.com/category/pool/">Pool</a></li>
	<li id="menu-item-151585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151585"><a href="https://kawowo.com/category/weightlifting/">Weightlifting</a></li>
	<li id="menu-item-151586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151586"><a href="https://kawowo.com/category/volleyball/">Volleyball</a></li>
	<li id="menu-item-151587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151587"><a href="https://kawowo.com/category/chess/">Chess</a></li>
	<li id="menu-item-151588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151588"><a href="https://kawowo.com/category/others/">Others</a></li>
	<li id="menu-item-151589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151589"><a href="https://kawowo.com/category/cycling/">Cycling</a></li>
	<li id="menu-item-151590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151590"><a href="https://kawowo.com/category/hockey/">Hockey</a></li>
	<li id="menu-item-151591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151591"><a href="https://kawowo.com/category/lacrosse/">Lacrosse</a></li>
	<li id="menu-item-151592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151592"><a href="https://kawowo.com/category/live/">Live</a></li>
	<li id="menu-item-151593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151593"><a href="https://kawowo.com/category/rowing/">Rowing</a></li>
	<li id="menu-item-151594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151594"><a href="https://kawowo.com/category/netball/">Netball</a></li>
	<li id="menu-item-151595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151595"><a href="https://kawowo.com/category/swimming/">Swimming</a></li>
	<li id="menu-item-151596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151596"><a href="https://kawowo.com/category/tennis/">Tennis</a></li>
</ul>
</li>
<li id="menu-item-151597" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151597"><a aria-haspopup="true" aria-expanded="false">STATS</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151598"><a href="https://kawowo.com/table/2019-20-upl-table/">UPL Table Standings</a></li>
	<li id="menu-item-151599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151599"><a href="https://kawowo.com/calendar/results/">All Results</a></li>
	<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="https://kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="https://kawowo.com/list/2019-20-uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-151602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

		
		
		<div class="middle-header-contain">
			<div class="wrapper">
				
									<div id="social-nav-contain" class="desktop-only">
											</div>
				
				

				<div class="site-branding">

			
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;103&quot; width=&quot;480&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></noscript></amp-img></a>	
	<div class="site-identity">
											<p class="site-title"><a href="https://kawowo.com/" rel="home">Kawowo Sports</a></p>
					
						<p class="site-description">
					East Africa's hub for Sports content				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

				

				<div class="nav-wrapper desktop-only">
					<div id="tertiary-nav-contain">
											</div><!-- #tertiary-nav-contain -->

					
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
				</div><!-- .nav-wrapper -->

									<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
						<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>						Menu					</button>
				
			</div><!-- .wrapper -->
		</div><!-- .middle-header-contain -->


					<div class="bottom-header-contain desktop-only">
				<div class="wrapper">
					<div id="site-navigation">
											</div>

									</div><!-- .wrapper -->
			</div><!-- .bottom-header-contain -->
		
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-cricket">
		<main id="main" class="site-main">

								<header class="entry-header">
						

	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://kawowo.com/category/cricket/" rel="category tag">Cricket</a></span>		<h1 class="entry-title ">
		Who makes the next generation of Lady Cricket Cranes?	</h1>
	
	<div class="entry-subhead">
		<div class="entry-meta">
			<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;80&quot; width=&quot;80&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://kawowo.com/author/denismusali/">Denis Musali</a></span> 			</span><!-- .byline -->
					<span class="posted-on"><time class="entry-date published" datetime="2020-05-30T16:33:42+03:00">May 30, 2020</time><time class="updated" datetime="2020-05-30T16:56:22+03:00">May 30, 2020</time></span>		</div><!-- .meta-info -->
		<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><!-- not supported: jetpack-whatsapp --><amp-social-share type="facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share><!-- not supported: telegram --><amp-social-share type="linkedin" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="1200" height="710" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?fit=1200%2C710&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=2048&amp;ssl=1 2048w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=480%2C284&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1200%2C710&amp;ssl=1 1200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=768%2C454&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1536%2C908&amp;ssl=1 1536w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=300%2C177&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=128%2C76&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=32%2C19&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1568%2C927&amp;ssl=1 1568w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=706%2C417&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=1920&amp;ssl=1 1920w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;710&quot; width=&quot;1200&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="1200" height="710" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?fit=1200%2C710&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=2048&amp;ssl=1 2048w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=480%2C284&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1200%2C710&amp;ssl=1 1200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=768%2C454&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1536%2C908&amp;ssl=1 1536w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=300%2C177&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=128%2C76&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=32%2C19&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=1568%2C927&amp;ssl=1 1568w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=706%2C417&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=1920&amp;ssl=1 1920w" sizes="(max-width: 1200px) 100vw, 1200px"></noscript></amp-img>						<figcaption>Immaculate Nakisuyi <span class="image-credit">Credit: John Batanudde</span></figcaption>
					
			</figure><!-- .post-thumbnail -->

		
<article id="post-153883" class="post-153883 post type-post status-publish format-standard has-post-thumbnail hentry category-cricket entry">
	<div class="entry-content">
		
<p>In naming my <a href="https://kawowo.com/2020/05/25/who-makes-the-lady-cricket-cranes-all-time-xi/" target="_blank" rel="noreferrer noopener">all-time Lady Cricket Cranes team</a> early this week, I highlighted mostly players who featured for the national side at the start of international cricket for the Ugandan ladies.</p>



<p>While the men had featured on the international scene since the early 1980s, it was not until 2001 that the Lady Cricket Cranes got a taste of international cricket. The lack of international cricket meant many good girls were caught in the bubble of life, choosing to move with their lives rather than wait for cricket to offer choices. </p>



<p>The new generation, however, has been fortunate enough to get a lot of international cricket in ICC or Regional Events. It’s with this generation that Uganda was able to be the become queens of African cricket as they toppled other nations because of a vibrant school program for girls cricket.</p><aside class="scaip scaip-1    "><aside id="newspack-ads-widget-3" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-web-5ed2735d18e96-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<p>Jinja SSS led the course for ladies cricket with Habib Mugalula helping many girls improve their skills and now, Soroti Academy is the resource in producing ladies’ talent.</p>



<p>Here are girls who have stood out in the new generation. </p>



<p><strong>1. Immaculate Nakisuyi</strong></p><aside class="scaip scaip-2    "><aside id="newspack-ads-widget-6" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-web-5ed2735d196c2-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120867 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120867" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-immaculate-nakisuyi-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Immaculate Nakisuyi batting against Zimbabwe during the Tri-Series at Lugogo <span class="image-credit">Credit: John Batanudde</span></figcaption></figure>



<p>Nakisuyi has been the x-factor for the Lady Cricket Cranes for the last three years. Since she burst on the scene as a youngster with Jinja SSS, Nakisuyi established herself as a game-changer. Her ability to hit sixes – a rarity in the ladies’ game – gave her the x-factor needed to change a team’s chances from losing to winning. She is a handy bowler but her batting ability is what gets Nakisuyi ahead of her peers. </p>



<p><strong>2. Susan Nampiina</strong></p>



<p>Nampiina is the only leg spinner in the ladies game, a rare skill to master. Nampiina horned her skills under Habib Mugalula at Jinja SSS and she became the go-to wicket-taker for the Lady Cricket Cranes. She is also a very agile fielder for the team with a commanding presence at point. The shy Nampiina is also a reliable middle-order batsman who can hit the ball far, no surprises she is close to Immaculate Nakisuyi. </p>



<p><strong>3. Rita Musamali</strong></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?w=960&amp;ssl=1" alt="" class="wp-image-122272 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=32%2C21&amp;ssl=1 32w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?w=960&amp;ssl=1" alt="" class="wp-image-122272" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/ritah-musamali-aziz-damani-cricket-1.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Rita Musamali batting for Aziz Damani <span class="image-credit">Credit: Cricket Uganda</span></figcaption></figure>



<p>The top all-rounder for the Lady Cricket Cranes now opens the bowling for the team and is also among the top three batters for the team. The girl from the hills of Sironko is not afraid to put her body on the line for the team, always digging deep for her runs and also fighting hard in the field. Musamali is another of Habib Mugalula’s proteges and she has more than given her best for the team. A first-year student at University, Musamali still has some more years with the Lady Cricket Cranes.</p>



<p><strong>4. Naomi Kayondo</strong></p>



<figure class="wp-block-image size-full is-style-default"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120738 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=32%2C21&amp;ssl=1 32w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120738" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/noami-kayondo-lady-cricket-cranes-batting-.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Naomi Kayondo batting against Zimbabwe during the Tri-Series at Lugogo <span class="image-credit">Credit: Cricket Uganda</span></figcaption></figure>



<p>Naomi Kayondo has fought a lone battle as an outsider of the popular cricket schools. She has worked hard on her game and is one of the finest batsmen for the Lady Cricket Cranes. A natural athlete, Kayondo is a marvel with the bat given her wide range of shot-making. She has also proven that you can have a successful career while also playing cricket at the highest level. An ECB Level 2 coach and the founder of Little Stumps Academy, Kayondo will clearly stay in cricket even her playing days are over.</p>



<p><strong>5. Janet Mbabazi</strong></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=900%2C600&amp;ssl=1" alt="" class="wp-image-143157 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=900%2C600&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=696%2C463&amp;ssl=1 696w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=1068%2C711&amp;ssl=1 1068w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=631%2C420&amp;ssl=1 631w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?w=1080&amp;ssl=1 1080w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=900%2C600&amp;ssl=1" alt="" class="wp-image-143157" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=900%2C600&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=696%2C463&amp;ssl=1 696w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=1068%2C711&amp;ssl=1 1068w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=631%2C420&amp;ssl=1 631w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/01/janet-mbabazi-cricket-uganda.jpg?w=1080&amp;ssl=1 1080w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Janet Mbabazi <span class="image-credit">Credit: Cricket Uganda</span></figcaption></figure>



<p>Janet Mbabazi is one of the first products of the Soroti Cricket Academy. Her all-round qualities have made her a reliable player for the Lady Cricket Cranes. She was able to fill the void left following the departure of Gertrude Candiru from the side. The multi-talented Mbabazi has also featured at the Softball World Cup and is also a fine footballer. She is also a very good leader of teams and knows how to read the game of cricket. </p>



<p><strong>6. Rachel Ntono</strong></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=899%2C600&amp;ssl=1" alt="" class="wp-image-74930 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=899%2C600&amp;ssl=1 899w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=480%2C321&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=768%2C513&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=32%2C21&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?w=900&amp;ssl=1 900w" width="899" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;899&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=899%2C600&amp;ssl=1" alt="" class="wp-image-74930" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=899%2C600&amp;ssl=1 899w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=480%2C321&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=768%2C513&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=32%2C21&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?resize=706%2C471&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2017/08/rachieal-musamali-jinja-ss-fails-to-run-out-ritah-ntono-olila.jpg?w=900&amp;ssl=1 900w" sizes="(max-width: 899px) 100vw, 899px" width="899" height="600"></noscript></amp-img><figcaption>Rita Musamali of Jinja SS fails to run out Rachel Ntono of Olila High in the final of the ladies T20 league. <span class="image-credit">Credit: Courtesy</span></figcaption></figure>



<p>In the T20 era, every side needs a player like Rachel Ntono who has the ability to score runs fast in the power play. Another product of Jinja and Habib Mugalula, Ntono is always quick to get the team out of the blocks and she has become a reliable player for the side. </p>



<p><strong>7. Damalie Busingye</strong></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120866 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=32%2C21&amp;ssl=1 32w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120866" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/04/jb-damalie-busingye-cricket-lady-cranes-vs-zimbabwe.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Damalie Busingye batting against Zimbabwe at Lugogo <span class="image-credit">Credit: John Batanudde</span></figcaption></figure>



<p>Damalie Busingye is one of the most technically gifted players in the ladies’ game. Busingye has a poise of a content batsman and she compliments Ntono’s power game when they open batting together. She has the knack to bat from the first ball to the last ball.</p>



<p><strong>8. Joyce Mary Apio</strong></p>



<p>A product of the Soroti Cricket Academy, very shy and humble, Apio only loses herself while bowling. She is fast enough to frighten fellow girls which gives her the edge to pick a lot of wickets. She is very down to earth girl, an attitude that has allowed her to improve her game since she came to study in Kampala. </p>



<p><strong>9. Kevin Awino</strong></p>



<figure class="wp-block-image size-large is-style-default"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120732 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?w=900&amp;ssl=1 900w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=696%2C464&amp;ssl=1 696w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=630%2C420&amp;ssl=1 630w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?w=960&amp;ssl=1" alt="" class="wp-image-120732" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?w=900&amp;ssl=1 900w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=696%2C464&amp;ssl=1 696w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=630%2C420&amp;ssl=1 630w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2019/04/kevin-awino-consy-aweko-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Kevin Awino and Consy Aweko</figcaption></figure>



<p>The current captain of the Lady Cricket Cranes is ever-present on the field as a wicketkeeper. She is reliable behind the stumps a position she has made her own for a long time now.  She is a very tidy batsman especially for her league side and sometimes for the national team once it is required. </p>



<p><strong>10. Esther Ilokur</strong></p>



<p>Ilokur is the future of the Lady Cricket Cranes from Soroti Cricket Academy. She captained the U19 side to a series win against Tanzania early this year and she is surely on the way up. Once Kevin Awino doesn’t have time to keep wickets for Uganda, Ilokur will surely do justice to the position. She won the young female cricketer of the year for 2018 and her star will definitely shine very bright.</p>



<p><strong>11. Prosociva Alako</strong></p>



<p> Proscovia Alako is one half of the record of the only 300 score in ladies’ cricket in T20 international cricket. Alako is a powerful hitter of the ball and although she is yet to feature for the Lady Cricket Cranes in an ICC event, she will definitely be an asset for the team in the future.</p>



<p><strong>12. Leona Babirye</strong></p>



<p>The twin is a fine accumulator of runs especially for her club Pioneer but a national team cap continues to elude her. However, she is a gifted batsman with impeccable timing due to her softball background. </p>



<p><strong>13. Evelyn Anyipo</strong></p>



<figure class="wp-block-image size-full is-style-default"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=960%2C640&amp;ssl=1" alt="" class="wp-image-153934 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?w=2048&amp;ssl=1 2048w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?w=1920&amp;ssl=1 1920w" width="960" height="640" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;640&quot; width=&quot;960&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=960%2C640&amp;ssl=1" alt="" class="wp-image-153934" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1200%2C800&amp;ssl=1 1200w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1536%2C1024&amp;ssl=1 1536w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=1568%2C1045&amp;ssl=1 1568w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?resize=706%2C471&amp;ssl=1 706w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?w=2048&amp;ssl=1 2048w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-evelyn-anyipo-lady-cricket-cranes.jpg?w=1920&amp;ssl=1 1920w" sizes="(max-width: 960px) 100vw, 960px" width="960" height="640"></noscript></amp-img><figcaption>Evelyn Anyipo <span class="image-credit">Credit: John Batanudde</span></figcaption></figure>



<p>Evelyn Anyipo is blessed with a height of a fast bowler and has used that reach to send down some fast stuff. Although she has not had a proper crack with the Lady Cricket Cranes, as long as she stays fit she cannot be ignored for long.</p>



<p><strong>Other Prospects</strong></p>



<p>There are some exciting girls coming out of the Soroti Cricket Academy and featured for the U19 girls’ team. Remember these names; Sarah Akiteng, Gloria Obukor, Kevin Amuge, Rachael Achan, Mary Akello and Christine Anayo. The other girls to look out for are; Maria Kagoya Nyende, Sarah Walaza and Susan Kakai, all from Jinja. </p>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-5ed2735d1ce57" aria-labelledby="related-posts-item-5ed2735d1ce57-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ed2735d1ce57-label" href="https://kawowo.com/2020/05/25/who-makes-the-lady-cricket-cranes-all-time-xi/">Who makes the Lady Cricket Cranes All-Time XI?</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/05/25/who-makes-the-lady-cricket-cranes-all-time-xi/"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2018/07/getrude-candiru-lady-cricket-cranes.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2018/07/getrude-candiru-lady-cricket-cranes.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">May 25, 2020</li><li class="jp-related-posts-i2__post-context">In "Cricket"</li></ul><ul id="related-posts-item-5ed2735d1cee0" aria-labelledby="related-posts-item-5ed2735d1cee0-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ed2735d1cee0-label" href="https://kawowo.com/2020/05/08/why-cricket-uganda-has-opted-for-foreign-coaches/">Why Cricket Uganda has opted for Foreign Coaches</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/05/08/why-cricket-uganda-has-opted-for-foreign-coaches/"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2017/05/an-steve-tikolo-cricket-cranes-coach.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2017/05/an-steve-tikolo-cricket-cranes-coach.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">May 8, 2020</li><li class="jp-related-posts-i2__post-context">In "Cricket"</li></ul><ul id="related-posts-item-5ed2735d1cf4d" aria-labelledby="related-posts-item-5ed2735d1cf4d-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ed2735d1cf4d-label" href="https://kawowo.com/2020/05/19/kayondos-lutaayas-and-more-ugandan-cricket-siblings/">Kayondos, Lutaayas and more... Ugandan Cricket Siblings</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/05/19/kayondos-lutaayas-and-more-ugandan-cricket-siblings/"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-hamu-kayondo-.jpg?fit=1200%2C1143&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/05/jb-hamu-kayondo-.jpg?fit=1200%2C1143&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">May 19, 2020</li><li class="jp-related-posts-i2__post-context">In "Cricket"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->

			
			<div class="author-bio">
				<amp-img alt="" src="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;80&quot; width=&quot;80&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/177ae95c0aea67e9b2d2f962b125939d?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						
						<div>
							<h2 class="accent-header">
								Denis Musali								<span></span>
							</h2>
							<div class="author-meta">
								<a class="author-email" href="mailto:denis.musali@kawowo.com">denis.musali@kawowo.com</a>
							</div>
						</div>
					</div><!-- .author-bio-header -->

											<p>
							Denis has represented Uganda in international cricket events including the World Cup. He is currently the captain of Wanderers Cricket Club.							<a class="author-link" href="https://kawowo.com/author/denismusali/" rel="author">
							More by Denis Musali							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
			
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please let us know what you think					<small><a id="cancel-comment-reply-link" href="/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/#respond" hidden data-amp-bind-hidden='commentform_post_153883.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_153883":{"replyToName":"","values":{"comment_parent":"0"}}} )'>Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form" method="get" action="//kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/" target="_top">
				<amp-iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=153883&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=8.5&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=fc5c78ca0881012b1540431fb05dd56167fbfa13#parent=https%3A%2F%2Fkawowo.com%2F2020%2F05%2F30%2Fwho-makes-the-next-generation-of-lady-cricket-cranes%2F" class="jetpack_remote_comment amp-wp-ed29df3 i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" height="400" layout="fixed-height" width="auto" data-amp-original-style="width:100%; height: 430px; border:0;" style="height:400px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=153883&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=8.5&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=fc5c78ca0881012b1540431fb05dd56167fbfa13#parent=https%3A%2F%2Fkawowo.com%2F2020%2F05%2F30%2Fwho-makes-the-next-generation-of-lady-cricket-cranes%2F" name="jetpack_remote_comment" class="jetpack_remote_comment amp-wp-ed29df3" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-amp-original-style="width:100%; height: 430px; border:0;"></iframe></noscript></amp-iframe>
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="">

		</div><!-- #comments -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
		<div class="sp-widget-align-none"><section id="sportspress-league-table-2" class="widget widget_sportspress widget_league_table widget_sp_league_table"><div class="sp-template sp-template-league-table">
	<div class="sp-table-wrapper"><table class="sp-league-table sp-data-table sp-sortable-table sp-responsive-table table_5ed2735d22d67 sp-scrollable-table sp-paginated-table" data-sp-rows="16"><thead><tr><th class="data-rank">Pos</th><th class="data-name">Team</th><th class="data-p">P</th><th class="data-w">W</th><th class="data-d">D</th><th class="data-l">L</th><th class="data-pts">Pts</th></tr></thead><tbody><tr class="odd sp-row-no-0"><td class="data-rank" data-label="Pos">1</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=480%2C481&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=419%2C420&amp;ssl=1 419w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=480%2C481&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=419%2C420&amp;ssl=1 419w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>Vipers SC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">16</td><td class="data-d" data-label="D">6</td><td class="data-l" data-label="L">3</td><td class="data-pts" data-label="Pts">54</td></tr><tr class="even sp-row-no-1"><td class="data-rank" data-label="Pos">2</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?w=512&amp;ssl=1 512w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=50%2C50&amp;ssl=1 50w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=64%2C64&amp;ssl=1 64w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?w=512&amp;ssl=1 512w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=50%2C50&amp;ssl=1 50w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=64%2C64&amp;ssl=1 64w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>KCCA FC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">15</td><td class="data-d" data-label="D">5</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">50</td></tr><tr class="odd sp-row-no-2"><td class="data-rank" data-label="Pos">3</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>SC Villa</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">13</td><td class="data-d" data-label="D">7</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">46</td></tr><tr class="even sp-row-no-3"><td class="data-rank" data-label="Pos">4</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=420%2C420&amp;ssl=1 420w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=32%2C32&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=420%2C420&amp;ssl=1 420w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=32%2C32&amp;ssl=1 32w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>Busoga United</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">13</td><td class="data-d" data-label="D">3</td><td class="data-l" data-label="L">9</td><td class="data-pts" data-label="Pts">42</td></tr><tr class="odd sp-row-no-4"><td class="data-rank" data-label="Pos">5</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>URA FC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">10</td><td class="data-d" data-label="D">10</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">40</td></tr></tbody></table></div><div class="sp-league-table-link sp-view-all-link"><a href="https://kawowo.com/table/2019-20-upl-table/">View full table</a></div></div>
</section></div><section id="newspack-ads-widget-2" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section>		<section id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widget-title accent-header"><span>Latest Updates</span></h2>		<ul>
											<li>
					<a href="https://kawowo.com/2020/05/30/who-makes-the-next-generation-of-lady-cricket-cranes/" aria-current="page">Who makes the next generation of Lady Cricket Cranes?</a>
											<span class="post-date">May 30, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/05/30/masaza-cup-2020-left-back-ssegonja-returns-to-gomba-from-ssingo/">Masaza Cup 2020: Left back Ssegonja returns to Gomba from Ssingo</a>
											<span class="post-date">May 30, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/05/30/kooki-ssaza-lures-aggressive-forward-ssemango/">Kooki Ssaza lures aggressive forward Ssemango</a>
											<span class="post-date">May 30, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/05/29/she-cranes-remain-unmoved-in-latest-netball-world-rankings/">She Cranes remain unmoved in latest netball world rankings</a>
											<span class="post-date">May 29, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/05/29/multichoice-partners-with-jumia-to-provide-access-to-dstv-and-gotv-merchandise-online/">MultiChoice partners with Jumia to provide access to DStv and GOtv Merchandise Online</a>
											<span class="post-date">May 29, 2020</span>
									</li>
					</ul>
		</section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section>	</aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

			<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;103&quot; width=&quot;480&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="text-3" class="widget widget_text"><h2 class="widget-title">About Us</h2>			<div class="textwidget"><p>© 2019 Kawowo Sports. All Rights reserved. Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>
<p><a class="button" href="mailto:advertising@owinosolutions.com">advertising@owinosolutions.com</a></p>
</div>
		</section><section id="text-5" class="widget widget_text"><h2 class="widget-title">Support Us</h2>			<div class="textwidget"><p>With the support of readers like you, we provide thoughtfully researched articles for a more informed and connected community. This is your chance to support credible, community-based, public-service journalism. Please join us!</p>
<p><a class="button" href="/support">Learn More</a></p>
</div>
		</section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2020 Kawowo Sports.</span>
				
				<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress.				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

		<amp-install-serviceworker src="/?wp_service_worker=1" data-iframe-src="https://kawowo.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics id="1ec50919b9fb" type="googleanalytics" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"account":"UA-20862137-4"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"}}}</script></amp-analytics>	
	













































































































			
		<!-- WooCommerce JavaScript -->

			
		
		
		

			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A8.5&amp;blog=119498450&amp;post=153883&amp;tz=3&amp;srv=kawowo.com&amp;host=kawowo.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 22 seconds ago
	generated in 1.469 seconds
	served from batcache in 0.003 seconds
	expires in 278 seconds
-->
