<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012006112352003">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="description" content="Douglas Bamweyana is a wonder researcher who loves his job on a 24-7 basis, often thinking well ahead of time to execute the next moves."><meta name="robots" content="index, follow"><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Bamweyana's Wakiso Giants project will surpass the bare minimum"><meta property="og:description" content="Douglas Bamweyana is a wonder researcher who loves his job on a 24-7 basis, often thinking well ahead of time to execute the next moves."><meta property="og:url" content="https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/"><meta property="og:site_name" content="Kawowo Sports"><meta property="article:publisher" content="https://www.facebook.com/kawowosports"><meta property="article:author" content="https://www.facebook.com/isabirye.david.96"><meta property="article:published_time" content="2020-06-28T07:26:18+00:00"><meta property="article:modified_time" content="2020-06-28T11:01:18+00:00"><meta property="og:image" content="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?fit=900%2C600&amp;ssl=1"><meta property="og:image:width" content="900"><meta property="og:image:height" content="600"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="@https://twitter.com/IsabiryeDavid"><meta name="twitter:site" content="@KawowoSports"><meta name="generator" content="Site Kit by Google 1.9.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Kawowo Sports"><meta name="application-name" content="Kawowo Sports"><meta name="generator" content="AMP Plugin v1.5.3; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><title>Bamweyana's Wakiso Giants project will surpass the bare minimum</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" async></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><link rel="icon" href="https://kawowo.com/wp-content/uploads/2020/04/icon-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="sportspress-roboto-css" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500&amp;subset=cyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext%2Cvietnamese&amp;ver=2.7" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css?family=Baloo+Thambi+2:400,500,600,700,800&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- This site is optimized with the Yoast SEO Premium plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://kawowo.com/#organization","name":"Kawowo Sports","url":"https://kawowo.com/","sameAs":["https://www.facebook.com/kawowosports","https://www.instagram.com/kawowosports/","https://www.youtube.com/c/Kawowo","https://en.wikipedia.org/wiki/Kawowo_Sports","https://twitter.com/KawowoSports"],"logo":{"@type":"ImageObject","@id":"https://kawowo.com/#logo","inLanguage":"en-US","url":"","caption":"Kawowo Sports"},"image":{"@id":"https://kawowo.com/#logo"}},{"@type":"WebSite","@id":"https://kawowo.com/#website","url":"https://kawowo.com/","name":"Kawowo Sports","description":"East Africa&#039;s hub for Sports content","publisher":{"@id":"https://kawowo.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://kawowo.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?fit=900%2C600&ssl=1","width":900,"height":600,"caption":"Douglas Bamweyana"},{"@type":"WebPage","@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#webpage","url":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/","name":"Bamweyana's Wakiso Giants project will surpass the bare minimum","isPartOf":{"@id":"https://kawowo.com/#website"},"primaryImageOfPage":{"@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#primaryimage"},"datePublished":"2020-06-28T07:26:18+00:00","dateModified":"2020-06-28T11:01:18+00:00","description":"Douglas Bamweyana is a wonder researcher who loves his job on a 24-7 basis, often thinking well ahead of time to execute the next moves.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/"]}]},{"@type":"Article","@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#article","isPartOf":{"@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#webpage"},"author":{"@id":"https://kawowo.com/#/schema/person/e77c3214629944d828b5d7b8b2dfb798"},"headline":"DAVID ISABIRYE: Bamweyana&#8217;s Wakiso Giants project will surpass the bare minimum","datePublished":"2020-06-28T07:26:18+00:00","dateModified":"2020-06-28T11:01:18+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#webpage"},"publisher":{"@id":"https://kawowo.com/#organization"},"image":{"@id":"https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#primaryimage"},"articleSection":"Football,Opinion","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#respond"]}]},{"@type":["Person"],"@id":"https://kawowo.com/#/schema/person/e77c3214629944d828b5d7b8b2dfb798","name":"David Isabirye","image":{"@type":"ImageObject","@id":"https://kawowo.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&d=mm&r=g","caption":"David Isabirye"},"description":"David Isabirye is a senior staff writer for Kawowo Sports where he covers most of the major events.","sameAs":["https://www.facebook.com/isabirye.david.96","https://www.instagram.com/davidisabirye","https://twitter.com/https://twitter.com/IsabiryeDavid"]}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Feed" href="https://kawowo.com/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Comments Feed" href="https://kawowo.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » DAVID ISABIRYE: Bamweyana’s Wakiso Giants project will surpass the bare minimum Comments Feed" href="https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/feed/"><link rel="https://api.w.org/" href="https://kawowo.com/wp-json/"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kawowo.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kawowo.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://kawowo.com/?p=155981"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2020%2F06%2F28%2Fdavid-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum%2F"><link rel="alternate" type="text/xml+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2020%2F06%2F28%2Fdavid-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum%2F&amp;format=xml"><link rel="manifest" href="https://kawowo.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"></head>

<body class="post-template-default single single-post postid-155981 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-nsub h-sb h-cl h-dh has-tertiary-menu has-sidebar has-featured-image single-featured-image-default">
		<div class="newspack_global_ad global_above_header">
			<div id="div-gpt-amp-kawowo-web-5ef8b2b6ba4c1-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-kawowo-web-5ef8b2b6ba4c1-970x90"><amp-ad width="970px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:90px;" i-amphtml-layout="fixed"></amp-ad></div> 
		</div>
			<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

				<nav class="tertiary-menu nav3" aria-label="Tertiary Menu" toolbar-target="tertiary-nav-contain" toolbar="(min-width: 767px)">
			<ul id="menu-tertiary-menu" class="menu"><li id="menu-item-151624" class="menu-highlight menu-item menu-item-type-post_type menu-item-object-page menu-item-151624"><a href="https://kawowo.com/support/">Support Us!</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-main-menu" class="main-menu"><li id="menu-item-151573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151573"><a href="https://kawowo.com/">Home</a></li>
<li id="menu-item-151574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151574"><a href="https://kawowo.com/football/">Football</a></li>
<li id="menu-item-151575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151575"><a href="https://kawowo.com/rugby/">Rugby</a></li>
<li id="menu-item-151576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151576"><a href="https://kawowo.com/motorsport/">Motorsport</a></li>
<li id="menu-item-151577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151577"><a href="https://kawowo.com/basketball/">Basketball</a></li>
<li id="menu-item-151578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151578"><a href="https://kawowo.com/golf/">Golf</a></li>
<li id="menu-item-151579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151579"><a href="https://kawowo.com/athletics/">Athletics</a></li>
<li id="menu-item-151580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151580"><a href="https://kawowo.com/cricket/">Cricket</a></li>
<li id="menu-item-151581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151581"><a href="https://kawowo.com/op-eds/">Op-Eds</a></li>
<li id="menu-item-151582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151582"><a href="https://kawowo.com/boxing/">Boxing</a></li>
<li id="menu-item-151583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151583"><a aria-haspopup="true" aria-expanded="false">More</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151584"><a href="https://kawowo.com/category/pool/">Pool</a></li>
	<li id="menu-item-151585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151585"><a href="https://kawowo.com/category/weightlifting/">Weightlifting</a></li>
	<li id="menu-item-151586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151586"><a href="https://kawowo.com/category/volleyball/">Volleyball</a></li>
	<li id="menu-item-151587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151587"><a href="https://kawowo.com/category/chess/">Chess</a></li>
	<li id="menu-item-151588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151588"><a href="https://kawowo.com/category/others/">Others</a></li>
	<li id="menu-item-151589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151589"><a href="https://kawowo.com/category/cycling/">Cycling</a></li>
	<li id="menu-item-151590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151590"><a href="https://kawowo.com/category/hockey/">Hockey</a></li>
	<li id="menu-item-151591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151591"><a href="https://kawowo.com/category/lacrosse/">Lacrosse</a></li>
	<li id="menu-item-151592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151592"><a href="https://kawowo.com/category/live/">Live</a></li>
	<li id="menu-item-151593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151593"><a href="https://kawowo.com/category/rowing/">Rowing</a></li>
	<li id="menu-item-151594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151594"><a href="https://kawowo.com/category/netball/">Netball</a></li>
	<li id="menu-item-151595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151595"><a href="https://kawowo.com/category/swimming/">Swimming</a></li>
	<li id="menu-item-151596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151596"><a href="https://kawowo.com/category/tennis/">Tennis</a></li>
</ul>
</li>
<li id="menu-item-151597" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151597"><a aria-haspopup="true" aria-expanded="false">STATS</a><button class="submenu-expand" tabindex="-1"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151598"><a href="https://kawowo.com/table/2019-20-upl-table/">UPL Table Standings</a></li>
	<li id="menu-item-151599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151599"><a href="https://kawowo.com/calendar/results/">All Results</a></li>
	<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="https://kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="https://kawowo.com/list/2019-20-uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-151602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

		
			
			<div class="middle-header-contain">
				<div class="wrapper">
					
											<div id="social-nav-contain" class="desktop-only">
													</div>
					
					
					<div class="site-branding">

	
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;103&quot; width=&quot;480&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://kawowo.com/" rel="home">Kawowo Sports</a></p>
					
						<p class="site-description">
					East Africa's hub for Sports content				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .nav-wrapper -->

											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							Menu						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

											</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-football category-opinion">
		<main id="main" class="site-main">

								<header class="entry-header">
						

	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://kawowo.com/category/football/" rel="category tag">Football</a></span>		<h1 class="entry-title ">
		DAVID ISABIRYE: Bamweyana’s Wakiso Giants project will surpass the bare minimum	</h1>
	
	<div class="entry-subhead">
		<div class="entry-meta">
			<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;80&quot; width=&quot;80&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://kawowo.com/author/david/">David Isabirye</a></span> 			</span><!-- .byline -->
					<span class="posted-on"><time class="entry-date published" datetime="2020-06-28T10:26:18+03:00">June 28, 2020</time><time class="updated" datetime="2020-06-28T14:01:18+03:00">June 28, 2020</time></span>		</div><!-- .meta-info -->
		<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><!-- not supported: jetpack-whatsapp --><amp-social-share type="facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share><!-- not supported: telegram --><amp-social-share type="linkedin" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:60px;height:44px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="900" height="600" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?fit=900%2C600&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=32%2C21&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="900" height="600" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?fit=900%2C600&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Douglas-Bamweyana.jpg?resize=32%2C21&amp;ssl=1 32w" sizes="(max-width: 900px) 100vw, 900px"></noscript></amp-img>						<figcaption>Douglas Bamweyana </figcaption>
					
			</figure><!-- .post-thumbnail -->

		
<article id="post-155981" class="post-155981 post type-post status-publish format-standard has-post-thumbnail hentry category-football category-opinion entry">
	<div class="entry-content">
		
<p class="has-drop-cap">The Richter magnitude scale is a special tool that measures the strength of an earthquake as developed by Charles F. Richter and presented in his landmark 1935 paper.</p>



<p>In footballing spheres, it could be borrowed temporarily to weigh the tension of coaches and their respective technical team members as they handle their respective football clubs in the box.</p>



<p>When the 2020-21 Uganda football season kicks off in October one of the coaches who will be in the dugout is Douglas Bamweyana.</p><aside class="scaip scaip-1    "><aside id="newspack-ads-widget-3" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-web-5ef8b2b6cf407-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<p>He will handle <a rel="noreferrer noopener" href="https://kawowo.com/2020/06/09/wakiso-giants-football-club-agree-on-bamweyana-wasswa-combo/" target="_blank">Wakiso Giants Football Club alongside Richard Wasswa as the first assistant</a>, Steven Bengo (second assistant) and Ali Kiggundu as the goalkeeping coach.</p>



<figure class="wp-block-image size-large"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?w=960&amp;ssl=1" alt="" class="wp-image-155719 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=706%2C471&amp;ssl=1 706w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?w=960&amp;ssl=1" alt="" class="wp-image-155719" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=480%2C320&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=128%2C85&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=32%2C21&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?resize=706%2C471&amp;ssl=1 706w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Wakiso Giants Head Coach, Douglas “Bamdagie” Bawenyana inks the treasured dotted lines on his employment contract at Wakiso Giants <span class="image-credit">Credit: Wakiso Giants Media</span></figcaption></figure>



<p>A CAF “A” certified coach, Bamweyana is a highly qualified sports scientist and possesses several enviable crucial documentations that include Masters in Sports Biomechanics from the school of Sport, Exercise and Health Sciences at Loughborough University, UK and a  Bachelor of  Sports Science from the Ivory Tower; Makerere University Kampala, Uganda, among others.</p>



<p>These qualifications aside, Bamweyana is a wonderful researcher who loves his job on a 24-7 basis, often thinking well ahead of time to execute the next five crucial moves ahead of him, just like the great chess guru Grand Master Gary Kasparov.</p><aside class="scaip scaip-2    "><aside id="newspack-ads-widget-6" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-web-5ef8b2b6cfc79-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<p>Bamweyana is one persona with extreme varying character traits. He is bold, patient, passionate, ambitious, decisive, has authority, faithful, devoted, tolerant, reliable, daring, friendly, courageous, confident, resourceful, charismatic, charming, proactive, articulate, adventurous, tough, brave, fearless, sincere, loyal, diligent, dauntless, smart, at times hot-tempered and bossy in a way.</p>



<p>He is very aggressive, more like a crocodile pouncing on an innocent prey by the lakeshore yet at times as calm as cucumber.</p>



<figure class="wp-block-image size-large"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?w=960&amp;ssl=1" alt="" class="wp-image-155982 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?w=858&amp;ssl=1 858w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=480%2C336&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=768%2C537&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=300%2C210&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=128%2C90&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=32%2C22&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=706%2C494&amp;ssl=1 706w" width="858" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;858&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?w=960&amp;ssl=1" alt="" class="wp-image-155982" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?w=858&amp;ssl=1 858w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=480%2C336&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=768%2C537&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=300%2C210&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=128%2C90&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=32%2C22&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/06/Bamweyana_hugs.jpg?resize=706%2C494&amp;ssl=1 706w" sizes="(max-width: 858px) 100vw, 858px" width="858" height="600"></noscript></amp-img><figcaption>Bamweyana greets the Ndejje University head coach Komakech during his SC Viilla epoch,</figcaption></figure>



<p>Last season, Bamweyana handled Maroons Football Club, still in the top flight division and had a fairy-tale in the opening stanza of the league before luck eluded the entire team in the closing part of the season.</p>



<p>Just like one of the previous coaches who handled the Purple Sharks, Charles Livingstone Mbabazi, Bamweyana is an exceptional planner, timekeeper and best of all, understands the demands of the contemporary football arena.</p>



<p>Bamweyana is someone who treasures his job to the dot, according it the due respect and worthwhile time.</p>



<p>He not only consults a lot but also invests personal resources to make ends meet.</p>



<p>I do vividly recount the telling times while still at Express, Sports Club Villa and lately Maroons, financial resources would delay.</p>



<p>He at times dug deep his own financial coffers to play patch up. Once in a while, he would motivate players with tokens and climb extra ladders to purchase club equipment as balls and training cones.</p>



<p>Wakiso Giants Football Club has its own philosophy, plans, dreams and rich ambitions.</p>



<p>The best well spelt out include among others sporting excellence on and off the field of play, become a model club not only in Uganda, East Africa but also on the African front as well as the ability to break even in the much competitive players’ market, a great fortune to end billions of money as a long time project.</p>



<p>Deep in my heart, I am aware that Bamweyana’s mission as being the best coach in Uganda, East Africa and Africa rhymes with the Wakiso Giants vivid dreams.</p>



<p>How and when he will excel at the club remains a detailed discussion that I reserve for another column on another fresh day and page.</p>



<div class="wp-block-image"><figure class="aligncenter size-full"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=635%2C900&amp;ssl=1" alt="" class="wp-image-155990 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=635%2C900&amp;ssl=1 635w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=480%2C680&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=212%2C300&amp;ssl=1 212w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=90%2C128&amp;ssl=1 90w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=23%2C32&amp;ssl=1 23w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=706%2C1001&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?w=762&amp;ssl=1 762w" width="635" height="900" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;900&quot; width=&quot;635&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=635%2C900&amp;ssl=1" alt="" class="wp-image-155990" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=635%2C900&amp;ssl=1 635w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=480%2C680&amp;ssl=1 480w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=212%2C300&amp;ssl=1 212w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=90%2C128&amp;ssl=1 90w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=23%2C32&amp;ssl=1 23w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?resize=706%2C1001&amp;ssl=1 706w, https://i0.wp.com/kawowo.com/wp-content/uploads/2020/06/douglas-bamweyana-wakiso-giants.jpg?w=762&amp;ssl=1 762w" sizes="(max-width: 635px) 100vw, 635px" width="635" height="900"></noscript></amp-img><figcaption>Douglas Bamweyana <span class="image-credit">Credit: John Batanudde</span></figcaption></figure></div>



<p>With the current lockdown (because of the Coronavirus pandemic), no one knows the exact date when sports will return in Uganda.</p>



<p>Despite the uncertainty, I am aware that Bamweyana has commenced the prior planning, enriching the squad as he brainstorms with the club directors and the other members on the technical team.</p>



<p>Between now and then (the training time), I am sure, he will have come out with the right modules and rich training programmes he is known for.</p>



<figure class="wp-block-image size-large"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=900%2C600&amp;ssl=1" alt="" class="wp-image-136282 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=900%2C600&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=1068%2C712&amp;ssl=1 1068w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=32%2C21&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?w=1080&amp;ssl=1 1080w" width="900" height="600" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;600&quot; width=&quot;900&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=900%2C600&amp;ssl=1" alt="" class="wp-image-136282" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=900%2C600&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=480%2C320&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=696%2C464&amp;ssl=1 696w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=1068%2C712&amp;ssl=1 1068w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=630%2C420&amp;ssl=1 630w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?resize=32%2C21&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/10/Bamweyana_Award.jpg?w=1080&amp;ssl=1 1080w" sizes="(max-width: 900px) 100vw, 900px" width="900" height="600"></noscript></amp-img><figcaption>Douglas Bamweyana shows off his accolade as the best coach in September 2020 <span class="image-credit">Credit: UPL</span></figcaption></figure>



<p>Bamweyana, the motivator, the elite coach, knowlegable and the aggressive character will excel with the Wakiso Giants project.</p>



<p>Only time will only reveal the truth as they recite over and over.</p>



<p>At the end of the day, the football seismological department will check the richter scale to determine from the logarithm of the amplitude of waves (successes vis-a-vis grey areas) in his tenure at the Purple Sharks.</p>



<p>Hopefully, the litmus test will read purple, the club’s dominant primary colour.</p>



<p>It is our Game, It is our Country. Fairplay</p>



<p><strong>Detailed Profile</strong></p>



<ul><li><strong>Full Name:</strong> Douglas Bamweyana</li><li><strong>Date of Birth:</strong> 14th October 1981</li><li><strong>Profession:</strong> Soccer Coach / Sports Scientist</li></ul>



<p><strong>Education: (&amp; Professional Qualifications):</strong></p>



<ul><li><strong>2018 –</strong> FUFA Manager’s License Student</li><li><strong>2016 –</strong> CAF A Football Coaching License</li><li><strong>2015 –</strong> CAF B Football Coaching License</li><li><strong>2011 –</strong> FA Level 2 Football Coaching License (Leicestershire – UK)</li><li><strong>2010 –</strong> FA Level 1 Football Coaching License (Leicestershire – UK)</li><li><strong>2009 –</strong> Certificate in Digital Notation / Match Analysis (Makerere University)</li><li><strong>2002 –</strong> Certificate in Sport Physiotherapy Lower Extremities. Eden Reha Gtz.</li><li><strong>2011 –</strong> MSc. in Sports Biomechanics (Distinction), School of Sport, Exercise and Health Sciences, Loughborough University, UK.</li><li><strong>2005 –</strong> BSc. Sports Science, Makerere University Kampala, Uganda.</li></ul>



<p><strong>Career Experience:</strong></p>



<ul><li>Makerere University Football Team</li><li>Express Football Club</li><li>Sports Club Villa</li><li>Maroons Football Club</li><li>Wakiso Giants Football Club (Current)</li></ul>



<blockquote class="wp-block-quote"><p>I am excited about the project, the quality of the lads and the challenge to build onto the already booming club image. I and my technical team bring lots of experiences and lessons – coupled with our commitment and determination. Our most ardent target is to help our players develop into the best version of themselves individually and as a group to help foster the club’s objectives. In the long run, we should certainly look to challenge on all fronts for honours within 3 years. The entire purple family should expect an attractive, creative and daring style of football – and lots of good times. But it goes without saying: a great dish takes time to prepare.</p><cite>Douglas Bamweyana, Wakiso Giants Football Club Head Coach</cite></blockquote>



<blockquote class="wp-block-quote"><p>What an excellent coach Wakiso Giants Football Club has got. I did not only work with Douglas Bamweyana but also studied with him and we shared the same CAF classes. He arrived at a time when many people believed coaching is for only those who played the game He was wholesomely embraced. He is one coach ready to develop players, with the capacity to develop the club and improve upon the club’s image before the general public. He will need time to turn around Wakiso Giants and management should give him the due time. He is tipped to be the next generation of coaches who will drive Uganda’s football to the next level.</p><cite>Alex Gitta, Uganda Wildlife Football Club Head Coach (Worked with Bamweyana at Express FC)</cite></blockquote>



<blockquote class="wp-block-quote"><p>As a club, we are delighted to have Bamweyana as our new head coach. He knows our expectations and those of our dear fans and we are optimistic he can play a lead role to take the club to another level.</p><cite>Sula Kamoga, Wakiso Giants Chief Executive Officer (CEO)</cite></blockquote>



<blockquote class="wp-block-quote"><p>Douglas Bamweyana is very organized in everything he executes. He loves an attack-minded philosophy of play. His ability to make research has often elevated him above many other coaches. I believe he will be proving many critics wrong at Wakiso Giants Football Club. This is the time to prove to the world and showcase all his potentiality</p><cite>Simon Peter Mugerwa, Bright Stars Assistant coach (Worked with Bamweyana at Sports Club Villa)</cite></blockquote>



<blockquote class="wp-block-quote"><p>He is a principled coach and a very good coach that I have ever worked with. He has particular beliefs and philosophy that he operates upon.</p><cite>Davis Mayanja, midfielder at Maroons FC</cite></blockquote>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-5ef8b2b6d32bb" aria-labelledby="related-posts-item-5ef8b2b6d32bb-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ef8b2b6d32bb-label" href="https://kawowo.com/2020/06/09/wakiso-giants-football-club-agree-on-bamweyana-wasswa-combo/">Wakiso Giants Football Club agree on Bamweyana – Wasswa combo</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/06/09/wakiso-giants-football-club-agree-on-bamweyana-wasswa-combo/"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/09/KAWOWO-6.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/09/KAWOWO-6.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">June 9, 2020</li><li class="jp-related-posts-i2__post-context">In "Football"</li></ul><ul id="related-posts-item-5ef8b2b6d333d" aria-labelledby="related-posts-item-5ef8b2b6d333d-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ef8b2b6d333d-label" href="https://kawowo.com/2020/06/24/wakiso-giants-confirm-douglas-bamweyana-as-new-head-coach/">Wakiso Giants confirm Douglas Bamweyana as new Head Coach</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/06/24/wakiso-giants-confirm-douglas-bamweyana-as-new-head-coach/"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2020/06/IMG-20200624-WA0021.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">June 24, 2020</li><li class="jp-related-posts-i2__post-context">In "Featured"</li></ul><ul id="related-posts-item-5ef8b2b6d33a0" aria-labelledby="related-posts-item-5ef8b2b6d33a0-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5ef8b2b6d33a0-label" href="https://kawowo.com/2020/03/25/david-isabirye-where-is-the-job-security-for-sacked-uganda-premier-league-coaches/">DAVID ISABIRYE: Where is the job security for sacked Uganda Premier League coaches?</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2020/03/25/david-isabirye-where-is-the-job-security-for-sacked-uganda-premier-league-coaches/"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2018/12/maroons_georgebest_nsimbe.jpg?fit=900%2C598&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;200&quot; width=&quot;350&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2018/12/maroons_georgebest_nsimbe.jpg?fit=900%2C598&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">March 25, 2020</li><li class="jp-related-posts-i2__post-context">In "Featured"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->

			
			<div class="author-bio">
				<amp-img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;80&quot; width=&quot;80&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						
						<div>
							<h2 class="accent-header">
								David Isabirye								<span></span>
							</h2>

															<div class="author-meta">
																			<a class="author-email" href="mailto:david@kawowo.com">
											<svg class="svg-icon" width="18" height="18" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M20 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V6c0-1.1-.9-2-2-2zm0 14H4V8l8 5 8-5v10zm-8-7L4 6h16l-8 5z"></path></svg>											david@kawowo.com										</a>
																										</div><!-- .author-meta -->
							
						</div>
					</div><!-- .author-bio-header -->

											<p>
							David Isabirye is a senior staff writer for Kawowo Sports where he covers most of the major events.							<a class="author-link" href="https://kawowo.com/author/david/" rel="author">
							More by David Isabirye							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
			
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please let us know what you think					<small><a id="cancel-comment-reply-link" href="/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/#respond" hidden data-amp-bind-hidden='commentform_post_155981.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_155981":{"replyToName":"","values":{"comment_parent":"0"}}} )'>Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form" method="get" action="//kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/" target="_top">
				<amp-iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=155981&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=8.6.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=2b957d603bd9b352650bd198207eaca8e750161f#parent=https%3A%2F%2Fkawowo.com%2F2020%2F06%2F28%2Fdavid-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum%2F" class="jetpack_remote_comment amp-wp-ed29df3 i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" height="400" layout="fixed-height" width="auto" data-amp-original-style="width:100%; height: 430px; border:0;" style="height:400px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><noscript><iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=155981&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=8.6.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=2b957d603bd9b352650bd198207eaca8e750161f#parent=https%3A%2F%2Fkawowo.com%2F2020%2F06%2F28%2Fdavid-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum%2F" name="jetpack_remote_comment" class="jetpack_remote_comment amp-wp-ed29df3" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" data-amp-original-style="width:100%; height: 430px; border:0;"></iframe></noscript></amp-iframe>
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="">

		</div><!-- #comments -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
		<div class="sp-widget-align-none"><section id="sportspress-league-table-2" class="widget widget_sportspress widget_league_table widget_sp_league_table"><div class="sp-template sp-template-league-table">
	<div class="sp-table-wrapper"><table class="sp-league-table sp-data-table sp-sortable-table sp-responsive-table table_5ef8b2b6d8a93 sp-scrollable-table sp-paginated-table" data-sp-rows="16"><thead><tr><th class="data-rank">Pos</th><th class="data-name">Team</th><th class="data-p">P</th><th class="data-w">W</th><th class="data-d">D</th><th class="data-l">L</th><th class="data-pts">Pts</th></tr></thead><tbody><tr class="odd sp-row-no-0"><td class="data-rank" data-label="Pos">1</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=480%2C481&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=419%2C420&amp;ssl=1 419w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=480%2C481&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/viperssc_logo-1.png?resize=419%2C420&amp;ssl=1 419w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>Vipers SC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">16</td><td class="data-d" data-label="D">6</td><td class="data-l" data-label="L">3</td><td class="data-pts" data-label="Pts">54</td></tr><tr class="even sp-row-no-1"><td class="data-rank" data-label="Pos">2</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?w=512&amp;ssl=1 512w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=50%2C50&amp;ssl=1 50w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=64%2C64&amp;ssl=1 64w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?w=512&amp;ssl=1 512w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=400%2C400&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=200%2C200&amp;ssl=1 200w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=32%2C32&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=50%2C50&amp;ssl=1 50w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=64%2C64&amp;ssl=1 64w, https://i2.wp.com/kawowo.com/wp-content/uploads/2016/12/kccafclogo-1.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>KCCA FC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">15</td><td class="data-d" data-label="D">5</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">50</td></tr><tr class="odd sp-row-no-2"><td class="data-rank" data-label="Pos">3</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/scvilla_logo.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>SC Villa</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">13</td><td class="data-d" data-label="D">7</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">46</td></tr><tr class="even sp-row-no-3"><td class="data-rank" data-label="Pos">4</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=420%2C420&amp;ssl=1 420w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=32%2C32&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?w=500&amp;ssl=1 500w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=480%2C480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=420%2C420&amp;ssl=1 420w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=128%2C128&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2019/08/busoga-united-logo.jpg?resize=32%2C32&amp;ssl=1 32w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>Busoga United</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">13</td><td class="data-d" data-label="D">3</td><td class="data-l" data-label="L">9</td><td class="data-pts" data-label="Pts">42</td></tr><tr class="odd sp-row-no-4"><td class="data-rank" data-label="Pos">5</td><td class="data-name has-logo" data-label="Team"><span class="team-logo"><amp-img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=96%2C96&amp;ssl=1 96w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;128&quot; width=&quot;128&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="128" height="128" src="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?fit=128%2C128&amp;ssl=1" class="attachment-sportspress-fit-icon size-sportspress-fit-icon wp-post-image" alt="" srcset="https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?w=400&amp;ssl=1 400w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=200%2C200&amp;ssl=1 200w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=128%2C128&amp;ssl=1 128w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=32%2C32&amp;ssl=1 32w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=50%2C50&amp;ssl=1 50w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=64%2C64&amp;ssl=1 64w, https://i0.wp.com/kawowo.com/wp-content/uploads/2016/12/urafc_logo.png?resize=96%2C96&amp;ssl=1 96w" sizes="(max-width: 128px) 100vw, 128px"></noscript></amp-img></span>URA FC</td><td class="data-p" data-label="P">25</td><td class="data-w" data-label="W">10</td><td class="data-d" data-label="D">10</td><td class="data-l" data-label="L">5</td><td class="data-pts" data-label="Pts">40</td></tr></tbody></table></div><div class="sp-league-table-link sp-view-all-link"><a href="https://kawowo.com/table/2019-20-upl-table/">View full table</a></div></div>
</section></div><section id="newspack-ads-widget-2" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section>		<section id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widget-title accent-header"><span>Latest Updates</span></h2>		<ul>
											<li>
					<a href="https://kawowo.com/2020/06/28/david-isabirye-bamweyanas-wakiso-giants-project-will-surpass-the-bare-minimum/" aria-current="page">DAVID ISABIRYE: Bamweyana’s Wakiso Giants project will surpass the bare minimum</a>
											<span class="post-date">June 28, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/06/27/turkish-super-lig-miya-features-as-10-man-konyaspor-kulubu-fall-to-besiktas/">Turkish Super Lig: Miya features as 10 man Konyaspor Kulubu fall to Besiktas</a>
											<span class="post-date">June 27, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/06/27/tanzania-premier-league-young-africans-displace-wadadas-azam-from-second-place/">Tanzania Premier League: Young Africans displace Wadada’s Azam from second place</a>
											<span class="post-date">June 27, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/06/27/mtn-recognized-as-most-admired-african-brand-in-uganda/">MTN recognized as most admired African brand in Uganda</a>
											<span class="post-date">June 27, 2020</span>
									</li>
											<li>
					<a href="https://kawowo.com/2020/06/27/sweden-superettan-bbakka-scores-for-umea-in-away-victory-over-10-man-afc-eskilstuna/">Sweden Superettan: Bbakka scores for Umeå in away victory over 10 man AFC Eskilstuna</a>
											<span class="post-date">June 27, 2020</span>
									</li>
					</ul>
		</section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/kawowo-web" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section>	</aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

			<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;charset=utf-8,<svg height=&quot;103&quot; width=&quot;480&quot; xmlns=&quot;http://www.w3.org/2000/svg&quot; version=&quot;1.1&quot;/>"></i-amphtml-sizer><noscript><img width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M20.007,3H3.993C3.445,3,3,3.445,3,3.993v16.013C3,20.555,3.445,21,3.993,21h8.621v-6.971h-2.346v-2.717h2.346V9.31 c0-2.325,1.42-3.591,3.494-3.591c0.993,0,1.847,0.074,2.096,0.107v2.43l-1.438,0.001c-1.128,0-1.346,0.536-1.346,1.323v1.734h2.69 l-0.35,2.717h-2.34V21h4.587C20.555,21,21,20.555,21,20.007V3.993C21,3.445,20.555,3,20.007,3z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="text-3" class="widget widget_text"><h2 class="widget-title">About Us</h2>			<div class="textwidget"><p>© 2019 Kawowo Sports. All Rights reserved. Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>
<p><a class="button" href="mailto:advertising@owinosolutions.com">advertising@owinosolutions.com</a></p>
</div>
		</section><section id="text-5" class="widget widget_text"><h2 class="widget-title">Support Us</h2>			<div class="textwidget"><p>With the support of readers like you, we provide thoughtfully researched articles for a more informed and connected community. This is your chance to support credible, community-based, public-service journalism. Please join us!</p>
<p><a class="button" href="/support">Learn More</a></p>
</div>
		</section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2020 Kawowo Sports.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack on WordPress.com				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

		<amp-install-serviceworker src="/?wp_service_worker=1" data-iframe-src="https://kawowo.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics id="1ec50919b9fb" type="googleanalytics" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"account":"UA-20862137-4"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"}}}</script></amp-analytics>	
	












































































































			
		<!-- WooCommerce JavaScript -->

			
		
		
		

			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A8.6.1&amp;blog=119498450&amp;post=155981&amp;tz=3&amp;srv=kawowo.com&amp;host=kawowo.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 21 seconds ago
	generated in 1.405 seconds
	served from batcache in 0.003 seconds
	expires in 279 seconds
-->
