<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1" i-amphtml-binding>
<head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link rel="preload" href="https://cdn.ampproject.org/v0.js" as="script"><link rel="preconnect" href="https://cdn.ampproject.org"><style amp-runtime="" i-amphtml-version="012106030132000">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</style><meta name="robots" content="max-image-preview:large"><meta name="description" content="It is a full house for the Uganda Cranes team in South Africa following the arrival of two players Moses Waiswa Ndhondhi and goalkeeper Ismael Watenga."><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Waiswa, Watenga train with the Uganda Cranes team in South Africa"><meta property="og:description" content="It is a full house for the Uganda Cranes team in South Africa following the arrival of two players Moses Waiswa Ndhondhi and goalkeeper Ismael Watenga."><meta property="og:url" content="https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/"><meta property="og:site_name" content="Kawowo Sports"><meta property="article:publisher" content="https://www.facebook.com/kawowosports"><meta property="article:author" content="https://www.facebook.com/isabirye.david.96"><meta property="article:published_time" content="2021-06-09T08:08:11+00:00"><meta property="article:modified_time" content="2021-06-09T10:40:58+00:00"><meta property="og:image" content="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?fit=900%2C560&amp;ssl=1"><meta property="og:image:width" content="900"><meta property="og:image:height" content="560"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="@IsabiryeDavid"><meta name="twitter:site" content="@KawowoSports"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="David Isabirye"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="2 minutes"><meta name="generator" content="Site Kit by Google 1.34.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="Kawowo Sports"><meta name="application-name" content="Kawowo Sports"><meta name="generator" content="AMP Plugin v2.1.2; mode=standard"><meta name="msapplication-TileImage" content="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//stats.wp.com"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//widgets.wp.com"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" async="" custom-element="amp-analytics"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><script src="https://cdn.ampproject.org/v0/amp-sticky-ad-1.0.js" async="" custom-element="amp-sticky-ad"></script><link rel="icon" href="https://kawowo.com/wp-content/uploads/2020/04/icon-32x32.png" sizes="32x32"><link rel="icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="sportspress-roboto-css" href="https://fonts.googleapis.com/css?family=Roboto%3A400%2C500&amp;subset=cyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext%2Cvietnamese&amp;ver=2.7" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-katharine-fonts-css" href="https://fonts.googleapis.com/css?family=Barlow%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css?family=Baloo+Thambi+2:400,500,600,700,800&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- This site is optimized with the Yoast SEO Premium plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://kawowo.com/#organization","name":"Kawowo Sports","url":"https://kawowo.com/","sameAs":["https://www.facebook.com/kawowosports","https://www.instagram.com/kawowosports/","https://www.youtube.com/c/Kawowo","https://en.wikipedia.org/wiki/Kawowo_Sports","https://twitter.com/KawowoSports"],"logo":{"@type":"ImageObject","@id":"https://kawowo.com/#logo","inLanguage":"en-US","url":"","caption":"Kawowo Sports"},"image":{"@id":"https://kawowo.com/#logo"}},{"@type":"WebSite","@id":"https://kawowo.com/#website","url":"https://kawowo.com/","name":"Kawowo Sports","description":"East Africa&#039;s hub for Sports content","publisher":{"@id":"https://kawowo.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://kawowo.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?fit=900%2C560&ssl=1","width":900,"height":560,"caption":"Uganda Cranes players getting ready for a training session at the SAFA center in South Africa (Credit: John Batanudde)"},{"@type":"WebPage","@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#webpage","url":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/","name":"Waiswa, Watenga train with the Uganda Cranes team in South Africa","isPartOf":{"@id":"https://kawowo.com/#website"},"primaryImageOfPage":{"@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#primaryimage"},"datePublished":"2021-06-09T08:08:11+00:00","dateModified":"2021-06-09T10:40:58+00:00","description":"It is a full house for the Uganda Cranes team in South Africa following the arrival of two players Moses Waiswa Ndhondhi and goalkeeper Ismael Watenga.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/"]}]},{"@type":"Article","@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#article","isPartOf":{"@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#webpage"},"author":{"@id":"https://kawowo.com/#/schema/person/e77c3214629944d828b5d7b8b2dfb798"},"headline":"Waiswa, Watenga train with the Uganda Cranes team in South Africa","datePublished":"2021-06-09T08:08:11+00:00","dateModified":"2021-06-09T10:40:58+00:00","mainEntityOfPage":{"@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#webpage"},"commentCount":0,"publisher":{"@id":"https://kawowo.com/#organization"},"image":{"@id":"https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#primaryimage"},"articleSection":"Featured,Football","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#respond"]}]},{"@type":"Person","@id":"https://kawowo.com/#/schema/person/e77c3214629944d828b5d7b8b2dfb798","name":"David Isabirye","image":{"@type":"ImageObject","@id":"https://kawowo.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=96&d=mm&r=g","caption":"David Isabirye"},"description":"David Isabirye is a senior staff writer for Kawowo Sports where he covers most of the major events.","sameAs":["https://www.facebook.com/isabirye.david.96","https://www.instagram.com/davidisabirye","https://twitter.com/IsabiryeDavid"]}]}</script><!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Feed" href="https://kawowo.com/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Comments Feed" href="https://kawowo.com/comments/feed/"><link rel="alternate" type="application/rss+xml" title="Kawowo Sports » Waiswa, Watenga train with the Uganda Cranes team in South Africa Comments Feed" href="https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/feed/"><link rel="https://api.w.org/" href="https://kawowo.com/wp-json/"><link rel="alternate" type="application/json" href="https://kawowo.com/wp-json/wp/v2/posts/185302"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://kawowo.com/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://kawowo.com/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://kawowo.com/?p=185302"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2021%2F06%2F09%2Fwaiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa%2F"><link rel="alternate" type="text/xml+oembed" href="https://kawowo.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fkawowo.com%2F2021%2F06%2F09%2Fwaiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa%2F&amp;format=xml"><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/kawowo.com\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&ref=DOCUMENT_REFERRER&popups=[]&settings={\"suppress_newsletter_campaigns\":\"1\",\"suppress_all_newsletter_campaigns_if_one_dismissed\":\"1\",\"suppress_donation_campaigns_if_donor\":false,\"newspack_popups_non_interative_mode\":false,\"newspack_popups_donor_landing_page\":\"\",\"all_segments\":{\"608c59ee8e1b6\":{\"min_posts\":\"15\",\"max_posts\":0,\"min_session_posts\":0,\"max_session_posts\":0,\"is_subscribed\":false,\"is_donor\":false,\"is_not_subscribed\":false,\"is_not_donor\":false,\"favorite_categories\":[],\"referrers\":\"\",\"referrers_not\":\"\",\"priority\":0},\"608c5a7ba0369\":{\"min_posts\":0,\"max_posts\":0,\"min_session_posts\":0,\"max_session_posts\":0,\"is_subscribed\":false,\"is_donor\":false,\"is_not_subscribed\":false,\"is_not_donor\":false,\"favorite_categories\":[12349],\"referrers\":\"\",\"referrers_not\":\"\",\"priority\":1}},\"newspack_popups_active_campaign_group\":false}&visit={\"post_id\":\"185302\",\"categories\":\"19927,12345\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://kawowo.com/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><!-- BEGIN Parse.ly 2.5.0 --><script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/kawowo.com\/2021\/06\/09\/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa\/"},"headline":"Waiswa, Watenga train with the Uganda Cranes team in South Africa","url":"http:\/\/kawowo.com\/2021\/06\/09\/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa\/","thumbnailUrl":"https:\/\/i1.wp.com\/kawowo.com\/wp-content\/uploads\/2021\/06\/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=80%2C80&ssl=1","image":{"@type":"ImageObject","url":"https:\/\/i1.wp.com\/kawowo.com\/wp-content\/uploads\/2021\/06\/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=80%2C80&ssl=1"},"dateCreated":"2021-06-09T08:08:11Z","datePublished":"2021-06-09T08:08:11Z","dateModified":"2021-06-09T08:08:11Z","articleSection":"Featured","author":[{"@type":"Person","name":"David Isabirye"}],"creator":["David Isabirye"],"publisher":{"@type":"Organization","name":"Kawowo Sports","logo":"https:\/\/kawowo.com\/wp-content\/uploads\/2020\/04\/cropped-kawowo_sports_logo_full-480x103-1.png"},"keywords":[]}
</script><!-- END Parse.ly --><!--noscript--><!--/noscript--><link rel="apple-touch-icon" href="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/icon.png?fit=80%2C80&amp;ssl=1"><title>Waiswa, Watenga train with the Uganda Cranes team in South Africa</title></head>

<body class="post-template-default single single-post postid-185302 single-format-standard wp-custom-logo wp-embed-responsive theme-newspack-theme woocommerce-no-js singular hide-homepage-title hide-site-tagline h-nsub h-sb h-cl h-dh h-cta has-tertiary-menu has-sidebar cat-featured cat-football has-featured-image single-featured-image-default">
			<div class="newspack_global_ad global_above_header">
								<div id="div-gpt-amp-kawowo-leaderboard-60c09f60052a5-320x50"><amp-ad width="320px" height="50px" type="doubleclick" data-slot="/21882621445/kawowo-leaderboard" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:320px;height:50px" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-kawowo-leaderboard-60c09f60052a5-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-leaderboard" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-kawowo-leaderboard-60c09f60052a5-970x90"><amp-ad width="970px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-leaderboard" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:90px" i-amphtml-layout="fixed"></amp-ad></div>			</div>
				<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

				<nav class="tertiary-menu nav3" aria-label="Tertiary Menu" toolbar-target="tertiary-nav-contain" toolbar="(min-width: 767px)">
			<ul id="menu-tertiary-menu" class="menu"><li id="menu-item-151624" class="menu-highlight menu-item menu-item-type-post_type menu-item-object-page menu-item-151624"><a href="https://kawowo.com/support/">Support Us!</a></li>
</ul>		</nav>

<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-main-menu" class="main-menu"><li id="menu-item-151573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151573"><a href="https://kawowo.com/">Home</a></li>
<li id="menu-item-151574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151574"><a href="https://kawowo.com/football/">Football</a></li>
<li id="menu-item-151579" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151579"><a href="https://kawowo.com/athletics/">Athletics</a></li>
<li id="menu-item-151575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151575"><a href="https://kawowo.com/rugby/">Rugby</a></li>
<li id="menu-item-151576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151576"><a href="https://kawowo.com/motorsport/">Motorsport</a></li>
<li id="menu-item-151577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151577"><a href="https://kawowo.com/basketball/">Basketball</a></li>
<li id="menu-item-151578" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151578"><a href="https://kawowo.com/golf/">Golf</a></li>
<li id="menu-item-151580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151580"><a href="https://kawowo.com/cricket/">Cricket</a></li>
<li id="menu-item-151581" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151581"><a href="https://kawowo.com/op-eds/">Op-Eds</a></li>
<li id="menu-item-151582" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-151582"><a href="https://kawowo.com/boxing/">Boxing</a></li>
<li id="menu-item-151583" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151583"><a aria-haspopup="true" aria-expanded="false">More</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151584"><a href="https://kawowo.com/category/pool/">Pool</a></li>
	<li id="menu-item-151585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151585"><a href="https://kawowo.com/category/weightlifting/">Weightlifting</a></li>
	<li id="menu-item-151586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151586"><a href="https://kawowo.com/category/volleyball/">Volleyball</a></li>
	<li id="menu-item-151587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151587"><a href="https://kawowo.com/category/chess/">Chess</a></li>
	<li id="menu-item-151588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151588"><a href="https://kawowo.com/category/others/">Others</a></li>
	<li id="menu-item-151589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151589"><a href="https://kawowo.com/category/cycling/">Cycling</a></li>
	<li id="menu-item-151590" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151590"><a href="https://kawowo.com/category/hockey/">Hockey</a></li>
	<li id="menu-item-151591" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151591"><a href="https://kawowo.com/category/lacrosse/">Lacrosse</a></li>
	<li id="menu-item-151592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151592"><a href="https://kawowo.com/category/live/">Live</a></li>
	<li id="menu-item-151593" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151593"><a href="https://kawowo.com/category/rowing/">Rowing</a></li>
	<li id="menu-item-151594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151594"><a href="https://kawowo.com/category/netball/">Netball</a></li>
	<li id="menu-item-151595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151595"><a href="https://kawowo.com/category/swimming/">Swimming</a></li>
	<li id="menu-item-151596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151596"><a href="https://kawowo.com/category/tennis/">Tennis</a></li>
</ul>
</li>
<li id="menu-item-169202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-169202"><a href="https://kawowo.com/stats/" aria-haspopup="true" aria-expanded="false">STATS</a><button class="submenu-expand" tabindex="-1" role="presentation"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" focusable="false" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M7.41 8.59L12 13.17l4.59-4.58L18 10l-6 6-6-6 1.41-1.41z"></path><path fill="none" d="M0 0h24v24H0V0z"></path></svg></button>
<ul class="sub-menu">
	<li id="menu-item-151598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151598"><a href="https://kawowo.com/table/2019-20-upl-table/">UPL Table Standings</a></li>
	<li id="menu-item-151599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151599"><a href="https://kawowo.com/calendar/results/">All Results</a></li>
	<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="https://kawowo.com/calendar/fixtures/">All Fixtures</a></li>
	<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="https://kawowo.com/list/2019-20-uganda-premier-league-top-scorers/">UPL top scorers</a></li>
</ul>
</li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social-menu" class="social-links-menu"><li id="menu-item-151602" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
<section id="newspack-ads-widget-11" class="below-content widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/sidebar_one" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'" i-amphtml-binding>

					
			<div class="middle-header-contain">
				<div class="wrapper">
					
											<div id="social-nav-contain" class="desktop-only">
													</div>
					
					
					<div class="site-branding">

	
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" data-hero-candidate="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic" data-hero i-amphtml-ssr><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjEwMyIgd2lkdGg9IjQ4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" alt="Kawowo Sports" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://kawowo.com/" rel="home">Kawowo Sports</a></p>
					
						<p class="site-description">
					East Africa's hub for Sports content				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false" i-amphtml-binding>
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'" i-amphtml-binding>
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false" i-amphtml-binding>
		
<form role="search" method="get" class="search-form" action="https://kawowo.com/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .nav-wrapper -->

					
					<a class="button mb-cta" href="https://kawowo.com/support/">Support Us</a>
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

											</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-featured category-football">
		<main id="main" class="site-main">

								<header class="entry-header">
						
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://kawowo.com/category/football/" rel="category tag">Football</a></span>			<h1 class="entry-title entry-title--with-subtitle">
			Waiswa, Watenga train with the Uganda Cranes team in South Africa		</h1>
				<div class="newspack-post-subtitle">
			Moses Waiswa and Ismael Watenga are based in South Africa where they ply their professional trade with SuperSport United and Chippa United respectively.		</div>
	

	<div class="entry-subhead">
					<div class="entry-meta">
				<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjgwIiB3aWR0aD0iODAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" height="80" width="80"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://kawowo.com/author/david/">David Isabirye</a></span> 			</span><!-- .byline -->
		<span class="posted-on"><time class="entry-date published" datetime="2021-06-09T11:08:11+03:00">June 9, 2021</time><time class="updated" datetime="2021-06-09T13:40:58+03:00">June 9, 2021</time></span>			</div><!-- .meta-info -->
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Enjoy with others:</h3><div class="sd-content"><amp-social-share type="whatsapp" height="32px" width="32px" aria-label="Click to share on WhatsApp" title="Click to share on WhatsApp" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="telegram" height="32px" width="32px" aria-label="Click to share on Telegram" title="Click to share on Telegram" data-share-endpoint="https://telegram.me/share/url?url=https%3A%2F%2Fkawowo.com%2F2021%2F06%2F09%2Fwaiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa%2F&amp;text=Waiswa%2C%20Watenga%20train%20with%20the%20Uganda%20Cranes%20team%20in%20South%20Africa" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="linkedin" height="32px" width="32px" aria-label="Click to share on LinkedIn" title="Click to share on LinkedIn" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="900" height="560" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?fit=900%2C560&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=480%2C299&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=768%2C478&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=300%2C187&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=128%2C80&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=32%2C20&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=400%2C249&amp;ssl=1 400w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=150%2C93&amp;ssl=1 150w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=706%2C439&amp;ssl=1 706w" sizes="(max-width: 900px) 100vw, 900px" data-hero-candidate="" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic" data-hero i-amphtml-ssr><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjU2MCIgd2lkdGg9IjkwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><img class="i-amphtml-fill-content i-amphtml-replaced-content" decoding="async" loading="lazy" alt="" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?fit=900%2C560&amp;ssl=1" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=480%2C299&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=768%2C478&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=300%2C187&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=128%2C80&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=32%2C20&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=400%2C249&amp;ssl=1 400w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=150%2C93&amp;ssl=1 150w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Uganda-Cranes-players-ready-for-a-training-session.jpeg?resize=706%2C439&amp;ssl=1 706w" sizes="(max-width: 900px) 100vw, 900px"></amp-img>						<figcaption>Uganda Cranes players getting ready for a training session at the SAFA center in South Africa (Credit: John Batanudde)</figcaption>
					
			</figure><!-- .post-thumbnail -->

		
<article id="post-185302" class="post-185302 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-football entry">
	<div class="entry-content">

		
		
<p>It is a full house in Uganda Cranes camp in South Africa following the arrival of two players, Moses Waiswa Ndhondhi and Ismael Watenga.</p>



<p>Waiswa and Watenga are based in South Africa where they ply their professional trade with SuperSport United and Chippa United respectively.</p>



<p>These two players trained with the rest of the other players moments after arrival in Johannesburg.</p><aside class="scaip scaip-1    "><aside id="media_image-3" class="widget_media_image clearfix"><a href="https://bigwin.ug" target="_blank" rel="noopener"><amp-img width="300" height="250" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?fit=300%2C250&amp;ssl=1" class="image wp-image-183516  attachment-full size-full amp-wp-enforced-sizes amp-wp-36746cb i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?w=300&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=128%2C107&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=32%2C27&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=150%2C125&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px" layout="intrinsic" disable-inline-width="" data-amp-original-style="max-width: 100%; height: auto;" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjI1MCIgd2lkdGg9IjMwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="300" height="250" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?fit=300%2C250&amp;ssl=1" alt="" loading="lazy" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?w=300&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=128%2C107&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=32%2C27&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=150%2C125&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px"></noscript></amp-img></a></aside></aside>



<figure class="wp-block-image size-full"><amp-img width="780" height="448" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=780%2C448&amp;ssl=1" alt="" class="wp-image-185305 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=480%2C276&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=768%2C441&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=300%2C172&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=128%2C74&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=32%2C18&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=400%2C230&amp;ssl=1 400w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=150%2C86&amp;ssl=1 150w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=706%2C406&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ0OCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="448" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=780%2C448&amp;ssl=1" alt="" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?w=900&amp;ssl=1 900w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=480%2C276&amp;ssl=1 480w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=768%2C441&amp;ssl=1 768w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=300%2C172&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=128%2C74&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=32%2C18&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=400%2C230&amp;ssl=1 400w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=150%2C86&amp;ssl=1 150w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/06/Ismael-Watenga-dives-during-a-Uganda-Cranes-training-session-in-South-Africa.jpeg?resize=706%2C406&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Ismael Watenga dives during a Uganda Cranes training session in South Africa (Credit: John Batanudde)</figcaption></figure>



<figure class="wp-block-image size-full"><amp-img width="780" height="540" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=780%2C540&amp;ssl=1" alt="" class="wp-image-185308 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=480%2C332&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=768%2C532&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=300%2C208&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=128%2C89&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=32%2C22&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=400%2C277&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=150%2C104&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=706%2C489&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjU0MCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="540" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=780%2C540&amp;ssl=1" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=480%2C332&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=768%2C532&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=300%2C208&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=128%2C89&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=32%2C22&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=400%2C277&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=150%2C104&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Okwi-Emmanuel-and-Denis-Onyango.jpeg?resize=706%2C489&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>New team captain Emmanuel Arnold Okwi with the outgoing captain Dennis Onyango (Credit: John Batanudde)</figcaption></figure>



<p>The team was received by former Uganda Cranes captain Denis Onyango.</p>



<p>They arrived well in the wee hours of Tuesday morning before they checked in at Protea Hotel Roodepoort, Johannesburg.</p>



<p>The first training session was conducted in the evening hours at the SAFA Technical Centre in Johannesburg.</p><aside class="scaip scaip-2    "><aside id="newspack-ads-widget-8" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-in-article-60c09f6015885-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-in-article" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<figure class="wp-block-image size-large"><amp-img width="780" height="521" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=780%2C521&amp;ssl=1" alt="" class="wp-image-185304 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=480%2C321&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=768%2C513&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=32%2C21&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=400%2C267&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=150%2C100&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=706%2C471&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjUyMSIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="521" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=780%2C521&amp;ssl=1" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?w=900&amp;ssl=1 900w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=480%2C321&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=768%2C513&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=128%2C85&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=32%2C21&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=400%2C267&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=150%2C100&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Goalkeepers-in-healthy-talk-session.jpeg?resize=706%2C471&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>The goalkeeping department in a healthy talk session (Credit: John Batanudde)</figcaption></figure>



<p>Head coach Abdallah Mubiru anticipates a good contest against South Africa on Thursday, 10th June 2021.</p>



<p>“We trained well for a week in Kampala before traveling to South Africa where we reached safely. The morale is high and everyone is mentally and physically ready for the game,” Mubiru noted.</p>



<p>The second and final training session will be held on Wednesday evening under floodlights.</p><aside class="scaip scaip-3    "><aside id="newspack-ads-widget-13" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-in-article-two-60c09f6015d9e-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/in-article-two" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<p><strong>Players:</strong></p>



<p><strong>Goalkeepers: </strong>Ismael Watenga (Chippa United, South Africa), Mathias Kigonya (Azam, Tanzania), Charles Lukwago (KCCA, Uganda)</p>



<p><strong>Defenders:</strong> Paul Willa (Vipers, Uganda), Mustafa Kizza (CF Montreal, Canada), Kayondo Abdu Aziizi (Vipers, Uganda), Enock Walusimbi (Express, Uganda), Juuko Murushid (Express, Uganda), Halid Lwaliwa (Vipers, Uganda), Mbowa Paul Patrick (URA, Uganda), Muhamud Hassan (Police, Uganda)</p><aside class="scaip scaip-4    "><aside id="newspack-ads-widget-9" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-in-article-threee-60c09f60162df-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/in-article-threee" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<p><strong>Midfielders:</strong> Lwanga Taddeo (Simba, Tanzania), Bobosi Byaruhanga (Vipers, Uganda), Shafik Kuchi Kagimu (URA, Uganda), Allan Okello (AC Paradou, Algeria), Waiswa Moses Ndhondhi (Super Sport United, South Africa), Abdul Lumala (Pyramids, Egypt), Ibrahim Orit  (Vipers, Uganda), Isma Mugulusi (Busoga United, Uganda), Steven Sserwadda (KCCA, Uganda)</p>



<p><strong>Forwards</strong>: Emmanuel Arnold Okwi (Captain; Al Ittihad Alexandria Club – Egypt), Mukwala Steven (URA, Uganda), Derrick Kakooza (Police, Uganda)</p>



<figure class="wp-block-image size-full"><amp-img width="780" height="480" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=780%2C480&amp;ssl=1" alt="" class="wp-image-185307 amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?w=1080&amp;ssl=1 1080w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=480%2C295&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=768%2C472&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=300%2C184&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=128%2C79&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=32%2C20&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=400%2C246&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=150%2C92&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=706%2C434&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjQ4MCIgd2lkdGg9Ijc4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img loading="lazy" width="780" height="480" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=780%2C480&amp;ssl=1" alt="" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?w=1080&amp;ssl=1 1080w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=480%2C295&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=768%2C472&amp;ssl=1 768w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=300%2C184&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=128%2C79&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=32%2C20&amp;ssl=1 32w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=400%2C246&amp;ssl=1 400w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=150%2C92&amp;ssl=1 150w, https://i2.wp.com/kawowo.com/wp-content/uploads/2021/06/Moses-Waiswa-in-training.jpg?resize=706%2C434&amp;ssl=1 706w" sizes="(max-width: 780px) 100vw, 780px"></noscript></amp-img><figcaption>Moses Waiswa in training session (Credit: FUFA Media)</figcaption></figure>



<p><strong>Officials:</strong></p><aside class="scaip scaip-5    "><aside id="newspack-ads-widget-10" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-kawowo-in-article-four-60c09f6016794-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/kawowo-in-article-four" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<ul><li><strong>Leader of Delegation</strong>: Kalibbala Chrizestom</li><li><strong>Head coach</strong>: Abdallh Mubiru</li><li><strong>Assistant coach:</strong> Livingstone Mbabazi</li><li><strong>Goalkeeping coach</strong>: Fred Kajoba Kisitu</li><li><strong>Team Coordinator:</strong> Geofrey Massa</li><li><strong>Team Doctor</strong>: Emmanuel Nakabago</li><li><strong>Kit Manager</strong>: Frank Bumpenje</li><li><strong>Media officer:</strong> John Batanudde</li><li><strong>National Teams officer:</strong> Paul Mukatabala</li><li><strong>FUFA Secretariat staff:</strong> Innocent Bagenayabo</li><li><strong>Delegates:</strong> Jamal Ngobi (Eastern Region FA) and Charles Mawadri  (West Nile Region FA)</li><li><strong>Journalist:</strong> Grace Mbabazi</li><li><strong>FUFA Official: </strong>Emmanuel Ndugga</li></ul>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-60c09f6017fab" aria-labelledby="related-posts-item-60c09f6017fab-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60c09f6017fab-label" href="https://kawowo.com/2021/06/07/five-u-20-players-make-the-uganda-cranes-squad-to-face-south-africa/">Five U-20 players make the Uganda Cranes squad to face South Africa</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2021/06/07/five-u-20-players-make-the-uganda-cranes-squad-to-face-south-africa/"><amp-img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/02/caf-bobosi-byaruhanga-steven-serwadda-uganda-hippos.jpg?fit=1200%2C863&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i2.wp.com/kawowo.com/wp-content/uploads/2021/02/caf-bobosi-byaruhanga-steven-serwadda-uganda-hippos.jpg?fit=1200%2C863&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">June 7, 2021</li><li class="jp-related-posts-i2__post-context">In "Football"</li></ul><ul id="related-posts-item-60c09f6017fee" aria-labelledby="related-posts-item-60c09f6017fee-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60c09f6017fee-label" href="https://kawowo.com/2021/05/26/akandwanaho-wafula-kambale-in-line-for-maiden-uganda-cranes-cap/">Akandwanaho, Wafula, Kambale in line for maiden Uganda Cranes caps</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2021/05/26/akandwanaho-wafula-kambale-in-line-for-maiden-uganda-cranes-cap/"><amp-img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/Joseph-Akandwanaho.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/Joseph-Akandwanaho.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">May 26, 2021</li><li class="jp-related-posts-i2__post-context">In "Football"</li></ul><ul id="related-posts-item-60c09f6018014" aria-labelledby="related-posts-item-60c09f6018014-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-60c09f6018014-label" href="https://kawowo.com/2017/08/15/typhoid-sidelines-onduparaka-defender-toha-from-uganda-cranes-training/">Typhoid sidelines Onduparaka defender Toha from Uganda Cranes training</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://kawowo.com/2017/08/15/typhoid-sidelines-onduparaka-defender-toha-from-uganda-cranes-training/"><amp-img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/02/an-match-referees-and-captains-pose-after-the-toss.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt="" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjIwMCIgd2lkdGg9IjM1MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/kawowo.com/wp-content/uploads/2017/02/an-match-referees-and-captains-pose-after-the-toss.jpg?fit=900%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" height="200" alt=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">August 15, 2017</li><li class="jp-related-posts-i2__post-context">In "Football"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
			</footer><!-- .entry-footer -->

	
			<div class="author-bio">
				<amp-img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjgwIiB3aWR0aD0iODAiIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIi8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/bf4f394b0ee6e64b56f7989d565a6c04?s=160&amp;d=mm&amp;r=g 2x" height="80" width="80"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						<div>
							<h2 class="accent-header">
								David Isabirye								<span></span>
							</h2>

															<div class="author-meta">
																			<a class="author-email" href="mailto:david@kawowo.com">
											<svg class="svg-icon" width="18" height="18" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M20 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V6c0-1.1-.9-2-2-2zm0 14H4V8l8 5 8-5v10zm-8-7L4 6h16l-8 5z"></path></svg>											david@kawowo.com										</a>
																		<ul class="author-social-links"><li class="facebook"><a href="https://www.facebook.com/isabirye.david.96" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path><title>facebook</title></svg></a></li><li class="twitter"><a href="https://twitter.com/IsabiryeDavid" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path><title>twitter</title></svg></a></li><li class="instagram"><a href="https://www.instagram.com/davidisabirye" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path><title>instagram</title></svg></a></li></ul>								</div><!-- .author-meta -->
							
						</div>
					</div><!-- .author-bio-header -->

											<p>
							David Isabirye is a senior staff writer for Kawowo Sports where he covers most of the major events.							<a class="author-link" href="https://kawowo.com/author/david/" rel="author">
							More by David Isabirye							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
		
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Please let us know what you think					<small><a id="cancel-comment-reply-link" href="/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/#respond" hidden data-amp-bind-hidden='commentform_post_185302.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_185302":{"replyToName":"","values":{"comment_parent":"0"}}} )' i-amphtml-binding>Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form" method="get" action="//kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/" target="_top">
				<amp-iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=185302&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=9.8.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=d4045147174e78504db64bd93faf3a1b5aa6e105#parent=https%3A%2F%2Fkawowo.com%2F2021%2F06%2F09%2Fwaiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa%2F" resizable="" layout="fixed-height" height="430" class="jetpack_remote_comment i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" style="height:430px" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><button overflow>Show more</button><noscript><iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=119498450&amp;postid=185302&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=0&amp;stb_enabled=0&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=Please+let+us+know+what+you+think&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=9.8.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=d4045147174e78504db64bd93faf3a1b5aa6e105#parent=https%3A%2F%2Fkawowo.com%2F2021%2F06%2F09%2Fwaiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa%2F" resizable height="430" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
											
									</iframe></noscript></amp-iframe>
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="">

		</div><!-- #comments -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
	<section id="media_image-2" class="widget widget_media_image"><a href="https://bigwin.ug" target="_blank" rel="noopener"><amp-img width="300" height="250" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?fit=300%2C250&amp;ssl=1" class="image wp-image-183516  attachment-full size-full amp-wp-enforced-sizes amp-wp-36746cb i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?w=300&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=128%2C107&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=32%2C27&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=150%2C125&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px" layout="intrinsic" disable-inline-width="" data-amp-original-style="max-width: 100%; height: auto;" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjI1MCIgd2lkdGg9IjMwMCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="300" height="250" src="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?fit=300%2C250&amp;ssl=1" alt="" loading="lazy" srcset="https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?w=300&amp;ssl=1 300w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=128%2C107&amp;ssl=1 128w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=32%2C27&amp;ssl=1 32w, https://i1.wp.com/kawowo.com/wp-content/uploads/2021/05/bigwin_give_18052021.png?resize=150%2C125&amp;ssl=1 150w" sizes="(max-width: 300px) 100vw, 300px"></noscript></amp-img></a></section><section id="newspack-ads-widget-2" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/sidebar_one" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section><section id="newspack-ads-widget-5" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/kawowo-sidebar-two" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries">
		<h2 class="widget-title accent-header"><span>Latest Updates</span></h2>
		<ul>
											<li>
					<a href="https://kawowo.com/2021/06/09/cheptegei-targets-1240-at-golden-gala/">Cheptegei targets 12:40 at Golden Gala</a>
											<span class="post-date">June 9, 2021</span>
									</li>
											<li>
					<a href="https://kawowo.com/2021/06/09/preps-for-2023-netball-world-cup-in-motion-as-logo-is-revealed/">Preps for 2023 Netball World Cup in motion as Logo is revealed</a>
											<span class="post-date">June 9, 2021</span>
									</li>
											<li>
					<a href="https://kawowo.com/2021/06/09/waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa/" aria-current="page">Waiswa, Watenga train with the Uganda Cranes team in South Africa</a>
											<span class="post-date">June 9, 2021</span>
									</li>
											<li>
					<a href="https://kawowo.com/2021/06/08/ogier-keen-to-add-safari-rally-to-his-victories/">Ogier keen to add Safari rally to his victories </a>
											<span class="post-date">June 8, 2021</span>
									</li>
											<li>
					<a href="https://kawowo.com/2021/06/08/onduparaka-parts-ways-with-mutyaba-name-successor-until-end-of-the-season/">Onduparaka parts ways with Mutyaba, name successor until end of the season</a>
											<span class="post-date">June 8, 2021</span>
									</li>
					</ul>

		</section><section id="newspack-ads-widget-12" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/sidebar-three" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section><section id="newspack-ads-widget-15" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/kawowo-sidebar-four" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section><section id="newspack-ads-widget-16" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="600" type="doubleclick" data-slot="/21882621445/kawowo-sidebar-five" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' data-multi-size="300x250,300x300" data-multi-size-validation="false" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:600px" i-amphtml-layout="fixed"></amp-ad></div></section><section id="newspack-ads-widget-18" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/kawowo-in-article" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px" i-amphtml-layout="fixed"></amp-ad></div></section></aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


				<div class="newspack_global_ad global_above_footer">
								<div id="div-gpt-amp-kawowo-footer-60c09f601d6c2-728x90"><amp-ad width="728px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-footer" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:728px;height:90px" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-kawowo-footer-60c09f601d6c2-970x90"><amp-ad width="970px" height="90px" type="doubleclick" data-slot="/21882621445/kawowo-footer" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:970px;height:90px" i-amphtml-layout="fixed"></amp-ad></div>			</div>
						<div class="newspack_amp_sticky_ad__container">
				<amp-sticky-ad class="newspack_amp_sticky_ad sticky i-amphtml-layout-nodisplay" layout="nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
					<amp-ad width="320" height="50" type="doubleclick" data-slot="/21882621445/kawowo-sticky" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"waiswa-watenga-train-with-the-uganda-cranes-team-in-south-africa","category":["featured","football"],"ID":185302}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:320px;height:50px" i-amphtml-layout="fixed"></amp-ad>				</amp-sticky-ad>
			</div>
		
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
			
		<a href="https://kawowo.com/" class="custom-logo-link" rel="home"><amp-img noloading="" width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9IjEwMyIgd2lkdGg9IjQ4MCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIiB2ZXJzaW9uPSIxLjEiLz4="></i-amphtml-sizer><noscript><img width="480" height="103" src="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?fit=480%2C103&amp;ssl=1" alt="Kawowo Sports" srcset="https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?w=480&amp;ssl=1 480w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=300%2C64&amp;ssl=1 300w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=128%2C27&amp;ssl=1 128w, https://i2.wp.com/kawowo.com/wp-content/uploads/2020/04/cropped-kawowo_sports_logo_full-480x103-1.png?resize=32%2C7&amp;ssl=1 32w" sizes="(max-width: 480px) 100vw, 480px"></noscript></amp-img></a>	<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-menu-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151602"><a target="_blank" rel="noopener" href="https://www.facebook.com/kawowosports"><span class="screen-reader-text">Facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151603"><a target="_blank" rel="noopener" href="https://www.instagram.com/kawowosports/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151604"><a target="_blank" rel="noopener" href="https://twitter.com/kawowosports"><span class="screen-reader-text">Twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151605"><a target="_blank" rel="noopener" href="https://www.youtube.com/channel/UCCisngWANaPlkg3OQquV-Rw"><span class="screen-reader-text">YouTube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
			<section id="text-3" class="widget widget_text"><h2 class="widget-title">About Us</h2>			<div class="textwidget"><p>© 2021 Kawowo Sports. All Rights reserved. Kawowo Sports Media is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>
<p><a class="button" href="mailto:advertising@owinosolutions.com">advertising@owinosolutions.com</a></p>
</div>
		</section><section id="text-5" class="widget widget_text"><h2 class="widget-title">Support Us</h2>			<div class="textwidget"><p>With the support of readers like you, we provide thoughtfully researched articles for a more informed and connected community. This is your chance to support credible, community-based, public-service journalism. Please join us!</p>
<p><a class="button" href="/support">Learn More</a></p>
</div>
		</section>		</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2021 East Africa's hub for Sports content.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

			<amp-analytics type="gtag" config='https://kawowo.com/wp-content/plugins/newspack-popups/includes/../api/segmentation/index.php?client_id=CLIENT_ID(newspack-cid)&amp;post_id=185302&amp;custom_dimensions=[{"role":"category","option":{"value":"category","label":"Category"},"gaID":"ga:dimension2"},{"role":"author","option":{"value":"author","label":"Author"},"gaID":"ga:dimension3"},{"role":"word_count","option":{"value":"word_count","label":"Word count"},"gaID":"ga:dimension4"},{"role":"publish_date","option":{"value":"publish_date","label":"Publish date"},"gaID":"ga:dimension5"}]&amp;custom_dimensions_existing_values={"dimension2":"football","dimension3":"David Isabirye","dimension4":360,"dimension5":"2021-06-09 11:08"}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-analytics>
				<amp-install-serviceworker src="https://kawowo.com/wp.serviceworker" data-iframe-src="https://kawowo.com/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"optoutElementId":"__gaOptOutExtension","vars":{"gtag_id":"UA-20862137-4","config":{"UA-20862137-4":{"groups":"default","linker":[],"send_page_view":false,"dimension2":"football","dimension3":"David Isabirye","dimension4":360,"dimension5":"2021-06-09 11:08"}}}}</script></amp-analytics><amp-analytics id="parsely" type="parsely" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"apikey":"kawowo.com"}}</script></amp-analytics><amp-analytics id="2a459a201ee9" type="googleanalytics" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"account":"UA-20862137-4"},"triggers":{"trackPageview":{"on":"visible","request":"pageview"}}}</script></amp-analytics>	
	




















































































			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
					
		<!-- WooCommerce JavaScript -->

			
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A9.8.1&amp;blog=119498450&amp;post=185302&amp;tz=3&amp;srv=kawowo.com&amp;host=kawowo.com&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
<!--
	generated 56 seconds ago
	generated in 1.088 seconds
	served from batcache in 0.003 seconds
	expires in 244 seconds
-->
